1

I just got this error trying to install ab on my Catalina macOS:

brew install homebrew/apache/ab     
Error: homebrew/apache was deprecated. This tap is now empty and all its contents were either deleted or migrated.

not sure what to do...

Actually what I want to do is to make ab work: I found out that ab (apache benchmark tool) is already installed on macOS, but it doesnt' work:

$ab
dyld: Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib
Referenced from: /usr/local/bin/ab
Reason: image not found
Abort trap: 6
4
  • It seems to be installed in /usr/local/bin so it is something you installed yourself. Do you remember how? – nohillside Sep 4 '20 at 17:51
  • @nohillside I read that ab is installed "by default" as is the apache web server... – Glasnhost Sep 4 '20 at 21:50
  • 2
    /usr/sbin/ab is installed by default. /usr/local/bin/ab is most certainly not. Also, a built-in binary would not try to read libraries from /opt/! – Wowfunhappy Sep 5 '20 at 1:19
  • @Wowfunhappy good point...my /usr/sbin/ab seems to work, but probably too late because I installed the library. Could have been that kind of problem then – Glasnhost Sep 5 '20 at 18:00
1

I found the solution on this post, https://github.com/kelaberetiv/TagUI/issues/635

brew uninstall openssl; brew uninstall openssl; 
brew install https://github.com/tebelorg/Tump/releases/download/v1.0.0/openssl.rb

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .