0

Spotlight is using a lot of CPU on my computer and I am tracking down why it is a problem.

I suspect it had something to do with time machine has I have a soft correlation to leaving my time machine drive plugged with spot light continually using CPU.

So I ran this command and it reports that spotlight is indexing my TM volume:

% mdutil -s "/Volumes/MBP15 Time Machine"
/System/Volumes/Data/Volumes/MBP15 Time Machine:
    Indexing enabled.

How do I turn off indexing of my time machine volume without having to run the command everytime I plug in my TM disk?

I tried adding it to the privacy tab and got this error:

enter image description here

I also tried to add the TM back up drive directly and got this:

enter image description here

2
  • 1
    If you're sharing a backup volume with multiple Macs (and possibly different versions of macOS), Spotlight might re-index those backups on each mount. I found this to be the case with Catalina TM volumes shared with Big Sur Macs. Solution is to use different TM volumes for Catalina and Big Sur.
    – Anders
    Aug 22, 2021 at 18:46
  • Maybe a duplicate of apple.stackexchange.com/questions/236059/… Sep 2, 2021 at 20:03

2 Answers 2

4

You can't. Spotlight is an integral part of Time Machine.

https://eclecticlight.co/2016/06/20/you-cannot-turn-off-spotlight-indexing-on-your-time-machine-backup/

As quoted there, Apple support pages used to say:

If you add a Time Machine backup disk to the privacy list, you will continue to see messages that Spotlight is indexing your backup disk. This indexing is necessary for Time Machine to function properly and can’t be disabled. Spotlight does exclude from searches any items you store on your backup disk that are not part of a Time Machine backup.

(Though they have rewritten them all for Catalina.)

So the real issue is not how to stop Spotlight from indexing, but work out why it's using so much CPU, and how to mitigate that. Sometimes, Spotlight needs to ramp up for a bit, but if it's happening more regularly, or constantly, then that might be a symptom of a problem with the backup's integrity.

Or it could just be that you're backing up thousands of small files every hour which require lots of processing, or a symptom of the drive being too full, or possibly too slow. Or something else. ;-)

-2

This is how you do that thing

  1. Open System Preferences > Spotlight
  2. Click the Privacy Tab
  3. Click the "+" button near the lower left of the window that opens
  4. Navigate to your Time Machine drive, click on the drive and click on the Choose button.

You have now excluded your Time Machine drive from Spotlight searches.

4
  • I did that and got the message shown in the original post. Sep 3, 2020 at 21:45
  • don't add the folder, add the ENTIRE drive (note step 4 says to select the drive) . It did this a while back when I had a local TM drive and it worked a treat Sep 3, 2020 at 21:47
  • Even if you could add the drive, adding the TM disk to the Spotlight exclusions doesn't stop it using Spotlight as part of TM.
    – benwiggy
    Sep 4, 2020 at 7:40
  • I have no idea what that means. Sep 4, 2020 at 12:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .