0

first query here. I'm being driven crazy by not being able to open one file from thousands. I'm using MacOS Catalina 10.15.6 & Excel for Mac 16.4.

When upgrading from Office 2011 every time I opened a .xls file I saved as .xlsx. Over the past three months I've saved thousands of files like this. Today, one refused to open. Dialogue boxes when attempting to open queried validity or extension name. The file was created in Excel six weeks ago and has been opened since with no problems. I opened similar, created at same time, both before and after attempting to open this one with no problem.

Then there's a message saying it may be read-only or encrypted. It's neither. I have permission to read and write (it's my own fil after all) and it hasn't been encrypted

I make a copy to see if that helps. Dialogue box says again it may be corrupted or read only and then laughably it might be on a server that isn't responding.

I've done everything I can think of. Zipped the file and tried to open unzipped. Changed file extension to .xls, changed application to open to first Numbers then OpenOffice. All without success.

Crazily, Excel's 'quick look' function works and I can see the file with all tabs and all data intact but can't do anything else from this option like a save as or export.

The get info box says the file was most recently opened today when of course it didn't open. But Excel's recently opened option doesn't show it at all.

One file. From literally thousands.

I've been using Excel since Office 2001 and I've never come across a version as bad as this current one. There are other issues but they're trifling compared to not being able to open an important file.

I've tried every help option possible but the only advice I can find is either something I've already tried or related to previous versions of Excel and aren't applicable here.

Any advice greatly appreciated.

Thanks in advance

4
  • 4
    Have you tried opening it in Numbers then making a new copy with export? – Solar Mike Aug 31 '20 at 10:57
  • 3
    It sounds like a damaged file. If you can I would try opening it on a Windows PC, that might work, especially if it is a newer version of Office. – Steve Chambers Aug 31 '20 at 12:36
  • 2
    Welcome to Ask Different. If you don't have access to a Windows PC, you can also try opening it on office.com (www.office.com is available to the general public free of charge, you will just need a Microsoft account). – jaume Aug 31 '20 at 13:30
  • 1
    Please try opening that file on another computer (send to a friend). If you can't open it there, it's likely that the file is corrupt. – Allan Aug 31 '20 at 20:50
0

Google Sheets can also open Excel files. Create a new sheet and once it loads go to File>Import. You can then Export, File>Download, as .xlsx. Might be worth a try... https://www.google.com/sheets/about/

0

The file is corrupt in such a way that Excel cannot read it. The suggestions provided are not out of belief they will work, but because Excel has no other ideas.

If you can view it with Quick Look, this is because it's not fully corrupted. Quick Look is not powered by Excel, it's provided by default in macOS and must be operating in a different fashion.

Applications like Preview or Numbers may be able to open the spreadsheet. Once open, you can try to extricate the data. Numbers can export to an Excel file which should correct it.

0

Thank you. Recent OS updates seem if not to have solved it then reduced the issue greatly. I've found the easiest thing to do is just quit Excel then relaunch and everything's fine

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .