2

I wanted to change the icons on Big Sur and ran into the same problems. I tried to follow the steps here (https://apple.stackexchange.com/a/395509/387852) but on step 6:

sudo mount -o nobrowse -t apfs DISK_PATH MOUNT_PATH

I ran into this issue

mount_apfs: volume could not be mounted: Resource busy
mount: /Users/timrupp/newicons failed with 75

I really am no programmer or have any real clue how to use Terminal. I'd appreciate any help.

  • 4
    What do you mean by „the same problems“? – nohillside Aug 30 at 9:27
  • Resource busy suggests something is running in the directory /Users/timrupp/newicons, for example did run your sudo command from there? If so, then do cd ~ ; sudo mount etc. – Philip Kearns Aug 30 at 10:33
  • I have yet to try macOS Big Sur because I don't waste time on beta products anymore, however, I'd attempt to replace icons from Terminal while still in macOS Recovery. – user3439894 Aug 30 at 14:44
  • @user3439894 you need to bless the snapshot afterwards for Big Sur to boot. Maybe I'll write a tutorial for it sometime. – Skeleton Bow Aug 30 at 19:18
  • @Skeleton Bow, Does selecting the Startup Disk from macOS Recovery bless it? A tutorial would be nice. However, I'm not moving to macOS Big Sur until at least 11.0.3 (if then, I wait and see hot things go). – user3439894 Aug 30 at 19:34
-3

diskutil unmountDisk force DISK_PATH (or whatever your disk is)

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .