I have an early 2015 Macbook Pro, and had High Sierra installed, on which I started having booting issues, due to which I finally resorted to a clean re-install via recovery mode to Catalina.

I was expecting some kind of new user setup on the new install, but when I fired it up, it reached the login screen. I could see the wallpaper, boot icons, text boxes and the blank user icon, but there was no text visible anywhere(No Username below the user icon, placeholder text in the text-boxes, {Sleep, Restart, Shut Down} below their respective icons)

P.S. On the upper tray, battery percentage and the Time still showed up as text.

Here's what I've tried-

  1. I booted into safe mode. That made the text show up, but now I had the issue of no user being available on the system. The username below the blank user icon was "Other...". I tried logging in with blank parameters, the login on my previous install, the classic root/toor. None of them worked.

  2. I booted in recovery mode, opened terminal-

    /sbin/fsck -fy
    #found no errors(It showed underallocated memory on my previous install, so guess that was fixed)
    /sbin/mount -uw /
    rm /var/db/.AppleSetupDone
    #This file was not found, confirmed with `ls -al /var/db/`

Didn't change a thing.

  1. In recovery mode, clicked Apple > Startup Disk Selected 'Macintosh HD C macOS, 10.15.6'(the only available option) and then Restart Again, took me to the text-less login screen.

  2. Opened Disk Utility in recovery mode This was the disk structure-


|-Macintosh HD C APFS MacOS 10.15.6 11.08GB/500.07GB

|-Macintosh HD C -Data APFS MacOS 10.15.6 40.25GB/500.07GB

Disk Images

|-macOS Base System DI Vol. MacOS 10.15.6 1.35GB/2GB

Ran the first aid on all volumes, no issues found, and didn't fix my problem.

Any help with this issue would be appreciated. This was my first time using a Mac, I hope I haven't made any blunders in the above solutions.

1 Answer 1


This was resolved, leaving it up in case anyone gets into a similar problem. Took the Mac to an Authorized Repair Shop, and they installed Mojave OS from a flash drive and this worked. An explanation they provided was that Downloading and Installing OS via Recovery mode may not handle network errors gracefully, and simply installs just the partial files which have been downloaded, which may have resulted in the above errors.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .