1

Several months ago I switched to a new laptop with Catalina on it. On this machine the passwords for sites that used to be stored in the browser are no longer being offered. I have to type them in every time.

Some sites do work properly as far as remembering cookies/logins - e.g. zillow.com - more of them do not. Examples of the latter include utexas.edu and for chase.com. I use Chase frequently and can see it in Google Password Manager:

enter image description here

But I have to enter the password every time anyways

The keychain does seem to be working: I can see plenty of entries in it. Here is recent history:

enter image description here

Also: Offer to save passwords is enabled:

enter image description here

Note that passwords are filled in /remembered for Safari

So why are passwords not being populated on Chrome? I am on macOS Catalina with latest chrome Version 84.0.4147.135

Update Based on comment from @JBallin

Go to your chrome settings. Under"Site Settings" - "Cookies" - you see an "Allow" button. Click on the "add" and then add: accounts.google.com (source) – JBallin 3 hours ago

I was looking for how to "allow" accounts.google.com . I do not see an "allow" button

enter image description here

Update again: now I foudn this under Cookies and other site data - and added accounts.google.com (i had previously added 2 sites that are still not working):

enter image description here

9
  • 1
    Pretty sure Safari/Keychain has nothing to do with Chrome. Keychain only works in Safari and Chrome handles passwords separately. Have you tried signing out of Chrome? Maybe a re-install? Also I'm not sure that this question pertains specifically to Apple - it may make more sense to ask on superuser instead.
    – JBallin
    Sep 21, 2020 at 16:18
  • @JBallin Thx. This happens only on a catalina laptop - not my mojave laptop or any other version previously : that's why I'm putting it here. I might do that reinstall of chrome. Sep 21, 2020 at 16:50
  • Here's something to try: Go to your chrome settings. Under"Site Settings" - "Cookies" - you see an "Allow" button. Click on the "add" and then add: accounts.google.com (source)
    – JBallin
    Sep 21, 2020 at 20:24
  • @JBallin Thx - I do not see an Allow" button. I am adding a screenshot to the question Sep 21, 2020 at 21:29
  • Don’t you need to click on “Cookies and site data” on the bottom?
    – JBallin
    Sep 21, 2020 at 21:33

2 Answers 2

0

I had a similar issue, it was a conflict between the keychain and Google chrome account password. Make sure to allow the use of the password from the keychain, from the popup that appears after a computer reboot.

0

"Keychain" is an app that runs on macOS. It interfaces only with macOS and iOS apps that come from Apple, such as Safari — it does not connect to or act with software like Chrome that doesn't come from Apple.

Google Password Manager does password management with Chrome, including Chrome running on macOS.

On this stack, the tag "Keychain" refers to Keychain the Apple app, not to password managers generally. You should delete this tag, and substitute the tag "Password."

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .