6

After updating my OS to Big Sur, I tried cloning a repo. In order to do so, I apparently need to install command-line tools. However, on Big Sur, whenever I try to download command-line tools, I get this warning and no installation.

enter image description here

3
  • @anki Scotts-iMac:Desktop scottlydon$ git init sh: line 1: 4306 Bus error: 10 /Applications/Xcode.app/Contents/Developer/usr/bin/xcodebuild -sdk /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk -find git 2> /dev/null git: error: sh -c '/Applications/Xcode.app/Contents/Developer/usr/bin/xcodebuild -sdk /.../SDKs/MacOSX.sdk -find git 2> /dev/null' failed with exit code 35328: (null) (errno=Invalid argument) xcode-select: Failed to locate 'git', requesting installation of command line developer tools. Aug 26, 2020 at 17:07
  • Check if you can use brew for the time being. Not a lot can be done for beta. How did you attempt to install the CLT ? Can you try downloading it from the website ?
    – anki
    Aug 26, 2020 at 17:10
  • I tried to install CLT from the popup that appeared when attempting git clone and then attempting to install it from the website. Brew worked just fine. Thank you! Aug 26, 2020 at 17:42

1 Answer 1

5

I fixed the same issue for me by downloading and installing the latest CLT package from https://developer.apple.com/download/more/

2
  • For some reason that didn't work for me. Only Home brew. Aug 27, 2020 at 1:08
  • 2
    This worked great. With the macOS beta I wasn't able to get right version of command-line tools using the standard approaches. Big Sur beta has been a big pain.
    – vhs
    Nov 27, 2020 at 8:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .