Sister has a macbook running 10.15.6 Catalina used to manage a Wordpress site on a virtual hosting service. As of a few days ago, the macbook fails to access the site and gets a "this site's IP has been changed" message. Phone and tablet on her same home network can access the site fine. I (on a different continent) can access the site fine. Nslookup for the site on her macbook gives the same result as it does for me. Hosting provider insists it's an IP cache issue on her machine.

Things she has already tried:

  • sudo killall -HUP mDNSResponder
  • DNS set to GoogleDNS
  • Safari, Firefox, and Chrome, all same issue
  • New user account on Macbook, Safari, same issue
  • Safari History->Clear History
  • Safari Preferences->Privacy->Manage Website Data->Clear All
  • Safari Develop->Empty Caches
  • Safari Develop->Page Resources->Network->Ignore Cache
  • Many restarts of Safari
  • Many reboots

Some more things tried since I originally posted:

  • accessing the site from daughter's Chromebook works fine
  • curl on her sitename also retrieves the same error page on her macbook

How Do I Fully Flush Cached Redirects From Safari? seems like it might be relevant? But perhaps not quite the same for Catalina?

Are we missing something obvious? All suggestions much appreciated.

  • You’re flushing the DNS cache which has nothing to do with that site. I would recommend clearing the cache, but that obviously didn’t work. As a test, create a new user account on the Mac and see if you can access the site from that one.
    – Allan
    Commented Aug 25, 2020 at 10:39
  • Thanks Allan we have done that, the new account also fails to access the site in the same way.
    – Kalessin
    Commented Aug 25, 2020 at 10:46
  • You should include that detail; edit the question to include it.
    – Allan
    Commented Aug 25, 2020 at 10:49
  • It is already there.
    – Kalessin
    Commented Aug 25, 2020 at 10:49
  • Sorry, you’re right. You should remove the code formatting as it makes reading it difficult which is why I missed it. Use bullet list instead
    – Allan
    Commented Aug 25, 2020 at 10:51

1 Answer 1


Solved, and obvious in hindsight: there was an entry for her site in /etc/hosts. Sister knows nothing about hostfiles and has no memory of editing it, but provider not so helpfully advises people to edit /etc/hosts to preview Wordpress ahead of domain transfers, and doesn't bother to warn them to clean up after, so we assume that's what happened.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .