I'm trying to do a clean install of macOS via USB on my MacBook Pro 2019 13". I have setup the boot security so that:

  1. It has medium security (I also tried no security) on bootable devices
  2. Allows the Mac to boot from an external drive.

I formatted my USB to Mac OS Extended (Journaled) with GDUI partition map. The USB with the macOS installer successfully shows on the startup manager. When I try and boot from it, however, I get this message:

enter image description here

I click update and I then get this error after seeing an Apple Logo (yes I was connected to internet):

enter image description here

So in conclusion I cannot boot from this USB.

The USB is of type USB-A that's connected through a USB-C hub, that could be the problem? Maybe a direct connection from a USB-C usb flash drive is better? Or the wrong formatting on the USB drive.

That's the only two I suspect. But then again, why isn't it updating?


  • 1
    I have seen cases where a USB hub will not allow a bootable USB to boot. Try 1) plugging hub into different port on Mac or 2) try using a USB-C to USB-A Female converter and plug directly into the Mac
    – Allan
    Aug 25, 2020 at 11:08
  • @Allan I think I may go out and purchase a USB-C flash drive too, I have a feeling that's the issue....lot's of people have ran into this and yet there is still no proper answer.
    – Nat
    Aug 25, 2020 at 11:12
  • That may be it. I recall this issue in an Xserve that wouldn’t boot USB unless it was in a particular port and not in a hub. But try the converter, chances are you’ll need it again as there are tons of USB-A devices out there. I use them all the time
    – Allan
    Aug 25, 2020 at 11:14
  • @Allan I assume there's specific drivers that are needed to use the hub as it supports anything you can think of. Theres no way it can function without some sort of driver, which may not be available in macOS recovery...
    – Nat
    Aug 25, 2020 at 11:16
  • You shouldn’t need drivers for a hub unless it has extra stuff like HDMI or Ethernet because during boot, those drivers aren’t loaded or in Recovery like you say.
    – Allan
    Aug 25, 2020 at 11:20

6 Answers 6


I faced this problem yesterday (and I solved it), here's the context:

TLDR; On the "Startup Disk Selection Screen", that appears after holding Option, connect a wifi network by searching for yours on the dropdown list). Doing this when the "it is necessary to make an update" screen appears and the computer will download the updates, make the update, automatically reboot, and you will be able to proceed with the installation without any problems.

Full Context: I wanted to have 2 different MacOS versions on my computer, so I created a Bootable USB with BigSur Installer (did all of this on my Catalina OS). I also partitioned my HD to install the other MacOS version of the mac but this is not relevant.

After creating this booable USB, I restarted my PC and held the Option key so I could see my bootable USB in there. I tried to install my new macOS Big Sur but I faced this same message "A software update is required to use this startup disk". I couldn't update choosing this option, I was stuck on the "try again screen". I solved this by doing the steps in the "TLDR" section above.

Hope it helps someone!

  • 1
    This answer helped me a lot and wanted to add more information for anyone else that finds this. What happened to me was even though I connected to a wifi network at the boot selection screen (after holding Option key at start up), when it brought me to the Recovery Assistant GUI with the message that it needed an update, I then had to connect again to wifi network before clicking on the "Update" button for this to work as it seems connecting at the boot selection screen doesn’t always pass through into the GUI. After doing this the update went through without a glitch.
    – Zappa
    Nov 9, 2022 at 4:10

In light of my discussion with Alan, I went out and got a dedicated USB-C Flash drive and it worked.

We concluded (not fact) that using something like a USB-C Hub would not work as it requires some sort of driver/software (that does not run within macOS recovery) to fully support it's functionality as it can support things like HDMI and ethernet, hence the reason the Mac wanted to updated something that didn't actually require an update.

Yet again, this is still an assumption, not fact. If you run into something similar for the future, then I recommend trying a dedicated USB-C flash drive (no hubs, extenders or converters).

  • Awesome! Glad you got it all sorted out! +1
    – Allan
    Aug 25, 2020 at 21:49
  • @Allan at least it answered the question - hopefully. Cheers for the support :)
    – Nat
    Aug 26, 2020 at 9:16
  • 1
    The answer below from Jonas F helped me work around this
    – ClintM
    Jan 25, 2021 at 18:25
  • 2
    fwiw neither a dedicated usb-c drive nor making sure I'm connected to wifi helped. I tried using ethernet instead (through a dongle) and even tried making a partition on my internal SSD and using that as a target for createinstallmedia to no avail. I just always get the "software update is required" message which seems to fail at some point in its install. I think I'm SOL, might need to go to the apple store.
    – adamdport
    Jul 21, 2021 at 14:38

Before pressing the "update" button, first enable WiFi via the icon at the top-right and connect to a network. Once the icon shows it is connect, then press the "update" button.

In my case, WiFi enabled automatically but didn't seem to remember the password for my network, so I had to enter it manually.

  • 1
    Nope. Connecting to a Wifi won't do it for me. The reason you need to enter WPA-password is obvious. You're not logged in with your Mac-user at that moment. Aug 30, 2021 at 8:35

What a nightmare.

I got this message, but the system seemed to crash at some point after clicking update and it wouldn't ever get past this. I tried the following to no avail:

  • Wiping the drive
  • Connecting via ethernet instead
  • Using a dedicated USB-C drive instead of going through a dongle
  • Reinstalling the original OS so I could run the Big Sur installer from there instead (High Sierra would install fine but Big Sur would continue to give the "software update is required" message upon reboot)
  • Resetting SMC, PRAM, etc

I ended up discovering that I could revive/restore the Apple T2 firmware as well using a second mac "host". This is done using the Configurator 2 app on the host computer connected to the problem computer using a USB-C cable connected to a specific USB port. Boot the problem computer into "DFU Mode" by doing their convoluted key combo sequence during boot, and then after selecting the DFU machine in Configurator, you can choose Actions - > Restore to begin the process.

I know it's frowned upon to include links without details, but booting into DFU mode is different depending on which mac you have. Here's a link to the article I used that shows them all: https://mrmacintosh.com/how-to-restore-bridgeos-on-a-t2-mac-how-to-put-a-mac-into-dfu-mode/

Here's a link to an Apple support article for specifically a 2018 Macbook Pro: https://help.apple.com/configurator/mac/2.7.1/#/apd0020c3dc2

Once you've done that you can now try to install Big Sur. Since your install media is undoubtedly on an external drive, you'll be told that booting from an external drive is not allowed. If you try to disable it from the Startup Security Utility, you might get a "no administrator was found" error, which means you can't actually allow booting from an external drive. To get past this, I ended up using Disk Utility to "restore" my SSD using my external installer's image. Voila, your installer is no longer an "external drive". I then added a partition to that drive (APFS) so that my installer partition would have something to install to.

Remove your external media (don't need it anymore), and hold down option on the next reboot so you can choose your installer partition. No more "software update is required" message!! Boom!

It's a long and convoluted process, but it worked for me. Hope this helps someone.

  • Does a system "crash" involve instant update failure on clicking update or try again or does it have any specific symptoms? Aug 30, 2021 at 8:43
  • After restarting to begin the update, it would show the progress bar for a bit, but then restart again and boot into the original OS as if nothing happened. No indication of failure, but no progress of any kind.
    – adamdport
    Sep 7, 2021 at 15:12

My solution to get my Mac to upgrade into 11.5.2 was to boot into recovery -R.

In recovery menu there is: Reinstall macOS Big Sur

Doing that did the upgrade successfully. No clean install, no data lost, no settings lost. Multiple failing options included: regular update from App Store, safe-mode boot / regular update, USB boot install, --R internet recovery. All ending in various errors.


I had this problem as well... same error.

I pressed the update buttons a few times with a lot of anger and it did work after 4-5 times really fast angry smashing that button. Maybe it helps someone! Was really frustrated as well!

  • Hey, welcome to SO. I don't think 'smash a button repeatedly' counts as an answer, I'm afraid. Look at the main community for guidance :)
    – Nat
    Feb 1, 2021 at 22:04
  • 1
    in the end it didn‘t work but it made the update - so it worked better than the other solutions! Anyways: I installed it easily by booting from my backup ssd and installed from there onto the deleted internal ssd. Ridiculous this procedure, Apple - shame on you.
    Feb 2, 2021 at 23:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .