1

Airdrop is not working on my macbook pro (early 2015, 13-inch, 8G, Mojave 10.14.6). To be more specific:

  1. My macbook can see and send files to my iphone and ipad, but not vice versa. My iphone and ipad cannot see my macbook in the Airdrop available devices.
  2. If I log out of my Apple ID, the airdrop function is back to normal, i.e. the macbook and iphone can see each other in Airdrop, and send files. However, as soon as I log in my Apple ID, the macbook just disappears from the Airdrop list, and no other device can find it anymore.
  3. Other LAN-related function seems not working either. For example, if I turn on ''File Sharing'' in System Preferences, my other macbook cannot see it in ``Network'' of Finder.

I have tried:

  1. Rebooting the macbook with or without Apple ID signed in.
  2. Turning on and off ``file sharing'' in System Preferences.
  3. Resetting PRAM with option+cmd+P+R while booting.
  4. Turning on and off the ``firewall'' function in Security & Privacy, System Preferences.
  5. Turning on and off wifi and bluetooth, allowing my device to be found by everyone/contacts/no one, etc.

I want to note again, that if I log out of my Apple ID, the airdrop function is back to normal completely. My macbook can be found and marked as a device of nobody's, and every function is working. However, as soon as I log into my Apple ID and authorise the macbook, it just disappears from the Airdrop list, and cannot be found by my ipad, iphone and other macbook anymore.

What on earth is wrong?? Any help is appreciated. Thanks in advance!

1
  • Hope you have allowed Everyone or Contacts only. Try to change and check it on both? – Udhy Aug 24 '20 at 13:04
1

Well, feel free to laugh at me. The above problem is caused by accidentally blocking my own Apple ID in imassages. Checked the block list of this app and removed my own Apple ID, and everything was back to normal.

For those having similar problems, I hope this question may help you out.

PS: My LAN-related functions are still not working. I am still trying to figure things out.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .