0

I have been trying to follow various posts on how to replace system default shortcuts, but been unable to replicate results. I'm currently on Mac OS 10.15.6.

Initial attempt

I want to remove the default shortcut:

Shift-Command-I: Open iCloud Drive.

And replace with a Services shortcut:

Shift-Command-I: New iTerm2 Window Here.

I've implemented the shortcut in the Keyboard page, however, the shortcut still just opens iCloud Drive when Finder is open. Outside of Finder, the shortcut works.

Next attempt

I've tried following posts on here, like this one on how to read and write global shortcuts, however I fail to find any. My assumption is that the shortcut would be available through com.developer.finder based on what I've read.

defaults write com.apple.finder NSUserKeyEquivalents -dict-add "iCloud Drive" nil

However, even after running this, I'm unable to see any NSUserKeyEquivalents.

defaults read com.developer.finder NSUserKeyEquivalents
# 2020-08-24 08:06:47.084 defaults[1073:19364]
# The domain/default pair of (com.developer.finder, NSUserKeyEquivalents) does not exist

I've tried running with "Open iCloud Drive", writing to com.apple.Finder, but nothing has worked.

Questions

So:

  • Have I fundamentally misunderstood how doing this is supposed to work?
  • Are the shortcuts under the Finder --> Go menu able to be changed in this way?
  • Is there another method to remove the open iCloud keyboard shortcut?

Thanks.

1
  • 2
    Just to firmly establish your method. The menu item isn't "Open iCloud Drive", it's just "iCloud Drive" on my Mac… That aside, the first thing you must do is replace that with garbage, or it will still fire. So, in App Shortcuts, set All Apps to 'iCloud Drive' trigger cmd/ctrl/opt/shift/F19 or something equally useless, then add your iTerm service as you already did. [Note shift/cmd/i is share>email in safari, so you might have to cover that separately] – Tetsujin Aug 24 '20 at 7:59
1

com.developer.finder is wrong.

com.apple.finder is more likely, but the shortcut is available in file dialogs, so may not be under the purview of the Finder.

First off, I'd try changing the shortcut to something else. Either do it in System Preferences, or try adapting your command from nil to -string "@$^~i"

(@ is Command; $ is shift, ^ is ctrl, ~ is alt.)

Next, you could try adding it to the user Global preferences.

defaults write -g NSUserKeyEquivalents -dict-add "iCloud Drive" -string "@$^~i"

However, it's equally possible that some key commands are hardwired and cannot be changed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .