1
  1. I download a large file, a 20GB DMG.
  2. Soon after, I ran out of space, I used the system information app to delete large files, including the 20 GB DMG.
  3. The System Information app crashed during this process, and I had to restart my laptop.
  4. Ever since, the System Manager still shows the DMG as occupying 20GB of space, but I cannot "open in Finder" or delete. Both the buttons do nothing.
  5. I tried searching for the said file, but found nothing.
  6. I have verified that the trash is empty.

I want to reclaim the 20GB of space that has been locked out, without having to format my disk again.

Storage Manager on Mac ( About -> Storage -> Manage ) still shows Dota 2 occupying 20.44GB

Selecting Dota 2 and clicking on "Show in Finder" does nothing. Looking for the file via ls -la does not show the file.

Applications folder does not show the file Applications folder does not show the file

Trash is empty Trash is empty

File type has changed to APPS_APPLS after updating to Big Sur, but no resolution to the problem.

File type has changed to APPS_APPLS after updating to Big Sur, but no resolution to the problem.

4
  • 2
    What is System Manager, can you add a screenshot showing details? Do the 20GB also show up in free disk space (so ist the free disk space about 20 GB lower than before the download)?
    – nohillside
    Commented Aug 27, 2020 at 8:11
  • I still wonder if the 20 GB are actually occupied or if you just see an inconsistent view here. Assuming you did install Dota before deleting it, can you open Terminal, run ls -ld /Applications/Dot* and report the result?
    – nohillside
    Commented Aug 27, 2020 at 11:39
  • I see no files found when running ls -ld /Applications/Dot*. Moreover, adding the size of all the other files in ~/Applications comes to ~ 41 GB, while the folder itself is occupying ~60 GB. I have some new information though, not sure if it helps. I upgraded to the Big Sur Beta, and the file type now shows up as APPS_APPLS.
    – Navid Khan
    Commented Aug 28, 2020 at 15:40
  • Does this answer your question? Disk space not freed up after deleting files and emptying Trash
    – pkamb
    Commented Aug 28, 2020 at 17:07

2 Answers 2

2

You need to empty your Trash. When you delete a file that just moves it to the trash. To free up space you must empty the trash.

Then you have to suspect that your spotlight process that feeds these displays is stuck. Log out of your account and then restart the mac.

See if you can reveal in finder the app below the one in question.

If the app in question is stuck, rebooting to recovery and then running disk utility to check / repair the filesystem would be prudent. Making a backup also would be prudent if this is a sign of directory damage. You can fix that easily with an erase / install - then load back the apps from backup.

2
  • Hi, I forgot to mention this in my comment, but I have also verified that the trash is empty. Also, since the file was deleted via the storage manager, it doesn't really go to the trash anyway. I think the app crashing has left the file in some weird state, where it is still occupying space, but not visible anywhere.
    – Navid Khan
    Commented Aug 27, 2020 at 8:07
  • @NavedKhan I’ve added substantial information here - your system is clearly not behaving well - let’s get a restart and check.
    – bmike
    Commented Aug 28, 2020 at 16:06
0

Apple menu > Restart. When the Apple logo appears, hold shift and then you'll boot into safe mode.

Check the free space there.

Apple menu > Restart. Don't hold anything this time. You'll boot into normal mode.

https://support.apple.com/HT201262

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .