2

MacBook Pro early 2013 3 Ghz Inte Core i7 running Mojave 10.14.6. Bought it used from Mac of All Trades about one year ago. Six months ago I replaced the internal SSD with a 1 Tb Aura SSD from OWC and cloned over the original contents. Everything has been great, no issues at all.

Starting about four days ago, I opened the clamshell to wake from sleep and nothing happened. I tried tapping keys for awhile. Then I tried pushing the power button, nothing. Held it for 10 seconds nothing. I thought it might've been lower in battery power than I realized so I connected AC power. Light goes green-orange like it should. I tried the power button again, and it boots up. I get to the login and everything is fine, the battery percentage does not show that is connected and charging. I disconnect and reconnect and no change: power is supposedly running on the battery even though it's plugged in. And then I notice that eventually the AC power plug glows green like it's fully charged but it's not showing that in the battery icon percentage.

Thinking there might be some kind of power management issue, I tried resetting the SMC. I shut down completely, disconnected AC, and pushed the key combination. Nothing! That freaked me out a little, so I tried again. This time it seemed to work. Once booted up, I see that percentage, charging, and or being on battery/AC still don't seem to be matching.

If I leave it to go to sleep, running on battery, I cannot get it to wake with clamshell opening or tapping keys. I have to either hold power until it chimes or reset SMC again. Coconut battery sometimes seems to be in sync with the battery gauge, sometimes it's not. Right now I have a green light on the power plug, but 89% charging in the battry icon and it hasn't changed in an hour.

I tried resetting the NVRAM, but nothing changed. I tried running the Apple Diagnostics but got an error message:

Error: 0x80000000000000003, Cannot Load 'EFI/Drivers/TestSupport.efi'
Status: 0x00000003 

I don't know what to do here. It's very nerve-wracking to not know if this thing is going to wake up at all. Once it's up and running it's fine. I have regular Time Machine backups for my content, but this computer is my livelihood (college professor).

Any ideas?


This is the output from the requested Terminal command:

Charge Information:
          Charge Remaining (mAh): 4631
          Fully Charged: No
          Charging: Yes
          Full Charge Capacity (mAh): 5449
      Health Information:
          Cycle Count: 857
          Condition: Normal
      Battery Installed: Yes
      Amperage (mA): 1811
      Voltage (mV): 12480

As it put this in, the power plug is showing green while battery is stuck at charging 89%.


I just tried using a different power cord, the plug shows green like before, no change in the battery percentage (still 89% and "charging").

I also cleaned the MagSafe 2 plug and port before this and they are clean (I originally thought it solved the issue until it started up again).

You mentioned that it might be a bad battery, which seems likely due to the age and cycles this one has. Apart from the inconvenience of messing with reboots and such, is there any danger or data loss or complete failure until I can arrange for a battery replacement?

3
2

Ordered a replacement battery kit, replaced the battery, ran through the battery conditioning charging cycles, and the MacBook is better than before. I noticed the old battery looked swollen when taking it out, so it was definitely done for.

I think we can say this question is answered: battery was bad and needed to be replaced. Thanks for your assistance and guidance!

2
  • Happy ending! You can also click the "accept" check mark button on your answer if you like. That tells future readers who may find this in a search that there is an accepted answer. – uhoh Aug 30 '20 at 10:52
  • 1
    Done and done. TY – trioxin Aug 31 '20 at 14:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .