Mac pro 2009 4,1 Boots up but no video output (black screen).

It was working fine on the old OS that was on it(not sure which OS). I want to update to the highest OS (el capitan) it can run. So I did. But after that I get an black screen.

I tried to reset some things like time code, vram etc. Nothing works. Can't even go to the BIOS to reset everything (or I've got the wrong key combination).

I have also added two other hdds. And on one of them was an Windows installation. So I hold the option key on startup to choose an other hdd and choose the Windows one. And that was just working fine.

What can I do to run Mac OS again? Also tried an Bootable USB with el Capitan but It won't recon the USB flash drive I've made on my 2019 Macbook pro.

When I use Option + Command + P + R And waited till the second time hearing the startup sound it looks like it's working fine.

But still no output. I see the Apple logo in the beginning but after that no output.

De Mac pro itselfs keeps running with no errors or blinking lights.

Gpu is an ATI Radeon HD 4870 512MB Mac Pro Graphics Card

6gb ddr3 ram And de standard Xeon 2,66 MHz cpu

Ive downloaded El Capitan, (it's in the downloads folder, DMG FILE).

Then I go to the terminal and I fill in:

sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/THENAMEOFMYFLASHDRIVE --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app

Fill in my password next, and than it says: ' sudo: /Applications/Install OS X El Capitan.app/Contents/Resources/createinstallmedia: command not found.

Catalina can't put it in de application folder for some wierd reason...

  • "it's in the downloads folder," .. your createinstallmedia input says it's in Applications...
    – Tetsujin
    Commented Aug 22, 2020 at 17:48
  • Your title says “not booting” but the first sentence says “boots up with no video.” Then there’s the Apple logo with nothing after. Can you clarify? Also, when you added the additional HDDs was that before or after you ran into this booting issue? If you’re getting the Apple logo, start in Verbose Mode - hold Cmd-V while booting and watch for error messages - you may need to record/photograph with your phone to capture them.
    – Allan
    Commented Aug 22, 2020 at 18:25

1 Answer 1


Adventures In Imaging El Capitan Bootable Media

According to this macOS KB Article (https://support.apple.com/en-us/HT201372)

"El Capitan downloads as a disk image. On a Mac that is compatible with El Capitan, open the disk image and run the installer within, named InstallMacOSX.pkg. It installs an app named Install OS X El Capitan into your Applications folder. You will create the bootable installer from this app, not from the disk image or .pkg installer."

I just attempted creating a bootable on Catalina and when running the PKG it says it will not install on this Mac as it is not compatible.

So I attempted to work around that problem. I had to use CharlesSoft's Pacifist utility which allows the extraction of any type of Mac Package file format. Since I am a MacSysAdmin I have this utility already and it comes in handy all the time. Unfortunately, it's not open source and it's not free. But for $20 shareware it does what it says it does and it does it very well.

I was able to extract the PKG from the DMG:

InstallMacOSX Folder
  └──InstallMacOSX Folder
       └──Install OS X El Capitan

Then I moved "Install OS X El Capitan" to "/Applications/Install OS X El Capitan" and then I ran the El Capitan "createinstallmedia" command.

sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app

Guess What? That Does Not Work!

I even tried using DiskMakerX ver 6 and ver 9 and it didn't work either. Stated my El Capitan was an incomplete download which it is not an incomplete download.

So back to the drawing board. I try it on Mojave instead. My Mac is dual boot Mojave / Catalina. So in Mojave, it still doesn't work.

Copy it over to the High Sierra Mac. Finally, some success. The DMG PKG file installed in /Applications/Install OS X El Capitan and I was able to burn a flash drive.

It Only Works on macOS High Sierra or older

So your options are to find someone with a High Sierra Mac or maybe you could install VirtualBox (free), Parallels, VMware Fusion and install High Sierra as a virtual machine then use that to burn an installer. FYI, it can be tricky to access a physical USB in a virtual machine.

Once you get it working, hang onto that working boot USB drive since it's such a terrific pain to build one! The way the El Capitan createinstallmedia works, varies considerably from the newer macOS versions. It doesn't have the normal InstallESD.dmg, etc.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .