Short version: Need help finding, diagnosing and fixing the internal factory installed Samsung SSD that has vanished after hard reset. Trying to retrieve data or avoid data loss with whatever options there are.

[Before I start I have links at bottom that may be similar problems that a more knowledgable person may be able to utilise to help here I am not sure.] I think this may be a similar fix with this: (I will post link later so it is not considered Spam) although the problems/causes are not the same.

So to begin: After a hard reset I found a flashing folder meaning no bootable drive. I was using High Sierra or later OS --I say later because am not sure what my last recent upgrade was if it was to later version High Sierra, Mojave, or Catalina but it was fairly recent and I had High Sierra before that for sure; so APFS was almost surely on the SSD format. I expect this solely from having High Sierra in use, which I had for a while.

I had no troubles but then had the OS freeze on Safari or chrome web stuff with multiple folders left open. I had maybe about 50G of space left on the SSD at the time of freeze. so I did a hard reset here (Just holding the power button to shut off) when I know I should have waited. Upon reboot I saw a dreaded flashing folder. Booting in recovery mode with only the internal SSD in (internet was required) I found that the factory Samsung internal SSD was not recognized--Only Disk0 and base OS X in Disk utility and Diskutil list from terminal. When trying to reload the OS from here (internet recovery) no disk or Hard drive/SSD was recognized. This is when I started learning about computers-- quick, and the importance of back-ups and stuff... Foolishly I did not have back up, and I must Say that I had just bought 2 San disks here to create back ups but I just never got to it. So the system froze up before I got to securing my data.

Anyway here I forget the exact order I did things and I should have written that down-- I know I did SMC reset. And the Boot into recovery--But the drive was not there to do anything that is recommended such as reinstalling the OS or doing first aid on the drive. I eventually put 2 different working OS-- [Catalina and Sierra] on two different external drives and also created a bootable drive on another hd.

So rationalizing-- did the hard reset mess with the drive during a super important root process? Did I get my partitions messed up as well?..From an improperly unmounted SSD? Was Bootloader or EFI boot loader locations scrambled?

I imagine that I must do the same thing as in another post: disable SIP and run some non intrusive fsck commands (get GPT FDisk as well??) to find out or fix stuff. But I am not sure and I need pro help to run any modifying commands for sure. I have scoured the support forums, but then got on here and this one seems quite intense--many with greater experience here who can help build up the resource.

I am trying to recover the drive so I can extract data and make use of the drive; or clone/copy the drive, then just reformat the SSD if that is safest? Make the SSD safe for use and I would keep all data on external drives ( I now have 3) this would be ideal. But another great outcome would be if the drive is mountable so I can at least access and extract the data I need, and go from there.

So what else to relate:

I can load into recovery mode (cmd + r) (cmd+Opt+R) both of which go into internet recovery.

I have 3 sandisks; (1 with Catalina, 1 with Sierra and one with data); and one toshiba drive with a sierra bootloader

In disk utility in recovery mode (with only the damaged/mixed drive in) I am only able to see Disk0 and OS X base system. Installing OSX from here (on external drive) yields the first OS X on this 2015 MBP which was Yosemite but no option there to show all devices in disk utility; in the view menu now in Sierra I ensure ‘Show all devices’ is enabled, and still no volume name for that which I would expect to see ‘Macintosh HD’ or SSD whatever it is named And I know I did the same in Catalina.

I contacted official Apple support (online), and once I explained that reseting SMC and PRAM didn't work and that I could see no drive names listed under my internal SSD, the girl mostly began talking about getting service for the hardware. So I later put Catalina on one of the external drives and system is running fine. (I am using Sierra now though on a different external drive) But still need to fix issue with internal drive and retrieve data.

I sincerely thought that if I could just put an AFPS system on the mac that it would be able to read the SSD... No

Cannot try Target disk mode on another Mac, I do not have one; I have a very old pc; but I would be blowing dust off of that so I doubt it can help.

Internet recovery mode works and safe mode but if I put in the internal SSD things seem to go real slow, and hot.

Recovery mode Disk Utility on the Internal SSD -- First Aid cannot be used as no disk is found

Thanks in advance for any help and time put forth.

-Will sleep now so apologies if I delay in any quick responses from the forum...

Thanks for reading!

Any more info needed?

MBP retina A1398 ...

2.2 ghz intel i7...

16gb 1600MHz DDR3...

15.4 inch mid 2015...

Boot ROM 199.0.0

SMC 2.29f23 ...

Model identifier 11,4..

SSD model info: [Samsung Model MZ-JPV2560/0A4 256GB SSUBX 655-1858F 2015.04]

MacBook Pro 15″, OS X 10.10 (installed)


2 Answers 2


The 15" MBP Retina Mid 2015 MacBookPro11,4 (A1398) is at most 5 years old. All drives fail, it is merely a matter of when. You have learned a valuable lesson about backups. It is interesting that Recovery Mode boots from the internal SSD or is that from an external drive? I suspect the latter but your description jumps around so much it's hard to tell.

While booted from an external drive if you open Terminal and run the diskutil list command do you see the internal physical drive /dev/disk0 listed with the EFI, Apple_Boot, Recovery? If not, then the drive is definitely not being seen at all. You could try booting from various macOS installer versions (Yosemite, High Sierra, Mojave, Catalina) on a flash thumb drive and run the Terminal and the diskutil list command on each. As the file systems vary from JHFS+ to APFS.

At this point you should probably just replace the internal SSD with a new SSD which fortunately is possible on this model of MacBook Pro. Newer MacBook Pros have the SSD soldered to the system board but not your model.

If you cannot see the drive at all is a clear indicator that the SSD has completely failed. If after replacing the SSD you cannot see the new drive then the system board has a failure. If it was merely a messed up core storage conversion to APFS or other soft failure of the data organization on the disk, it would still show up as a drive. It would appear even if nothing was on the drive.

You can send the SSD out to a data recovery company to take a crack at recovering data but it can be very expensive. It may require removing the flash chips and placing them in a special rig using very specialized software to read every sector bypassing the drives firmware. Then more software to decode various layers of core storage and JHFS+ or APFS formatting. Even then you might receive back a jumbled mess of partial data. The more effort involved in recovery the more it costs. When SSDs fail there is often no warning unlike mechanical HDD drives which make noises, report failures, etc.

But sadly, you will not find any magic bullet software to fix/repair a drive that is not being detected. At that point, your options require significant tooling and skill to access the flash chips directly. If it was encrypted you need to supply the recovery key to the data recovery specialists.

  • Great info. Both CMD+ R and option +cmd+ R seem to use the internet when booting only the internal drive is in-no external drives plugged in. Yes the question write up is terrible because I do not know how to present this kind of info logically. Before this, I tried to set up time machine but I didn't know the drive had to be formatted, so it shows how much i knew beforehand. Now I see that my external drive is formatted in exfat for my MacBook so...yeah laughable. I will do what you recommend and report here. I also wanted to try to put High Sierra on and reinstall OS if SSD is seen. Thx! Commented Aug 22, 2020 at 14:06
  • 1
    If you still want to recover the internal drive do not attempt to install anything to it or you will destroy whatever data is there. If you've done that already your chances of recovering data is unlikely. SSD sectors do not have the same recovery chances as spinning metal with magnetic properties where you could undelete or even unformat. SSD firmware also zeros out sectors marked as deleted as well as an OS using TRIM support. Forensic people are not fans of Solid State Disks as a result. Especially when the drive firmware wipes sectors. Commented Aug 22, 2020 at 14:49
  • Ok thanks for telling me that- I will not attempt to reinstall the OS (on internal drive ) while using an external SSD that has Catalina. Commented Aug 22, 2020 at 15:33
  • 1
    So at this point I am only going to take action by:[ "You could try booting from various macOS installer versions (Yosemite, High Sierra, Mojave, Catalina) on a flash thumb drive and run the Terminal and the diskutil list command on each. As the file systems vary from JHFS+ to APFS."] and I will be purchasing both: a small internal SSD; and the external OWC SSD enclosure for macs 2013-2015 and slowly narrow this down. Commented Aug 22, 2020 at 15:54
  • Update, I am going to wait until I get this SSD into an external enclosure and get the data off- It may be something simple to do with Kext signatures or needing to reinitialize the SSD which would wipe it. I installed a Taiwan brand SSD and it behaved the same as the factory drive ( which is a Samsung) Something happened during that crash that rendered the drive inoperable. Commented Aug 22, 2020 at 22:02

I would probably take the drive from the mac so you can test the drive in isolation. It seems there’s so much history and effort to fix this with the drive in, it’s time to simplify your challenge.

Once you have the drive in another controller - you can recover the data or know the drive is in fact failed and seek professional data recovery.

James has the other brilliant idea - just bring an external drive to the mac in question and see if you can install an OS on an external drive - if you can’t do that, you know your mac needs repair, so it’s more urgent to get the drive out once you do that experiment.

  • 1
    Yes I have 2 external SSDs which I have installed Catalina on one and Sierra on another. So the mac works fine but James is still right saying there could be a system board failure if I install another internal SSD and that one does not work. The drive is not in the mac right now- and I do not yet have the required: [OWC SSD enclosure for Mac 2013-2015] to test externally. Will be looking in town for that tomorrow (I'm in Taiwan now) They actually make IC parts for drives here SKHynix or something? Commented Aug 22, 2020 at 15:44
  • 1
    Seems a standard NVMe PCIE 3.0 M.2 2280 Internal SSD will work. It's nothing special just a standard drive. Commented Aug 22, 2020 at 15:59
  • People have used "a standard NVMe PCIE 3.0 M.2 2280 Internal SSD" successfully? I thought it had to be a proprietary APPLE drive, or the OWC Aura Pro X2 made specifically for Apple? What was all that 1 in a million talk I heard about? Commented Aug 22, 2020 at 17:25
  • So I am waiting until I can buy the external enclosure hopefully later today. I will get the data off and then report if it is indeed OK or still invisible. I wrote above-- It may be something simple to do with Kext signatures?? that i read about or needing to reinitialize the SSD which would wipe it. I installed a Taiwan brand SSD and it behaved the same as the factory installed drive (which is a Samsung) and the machine got really hot fast. Something happened during that crash that caused this behaviour. I will take the next step and report my findings. Commented Aug 22, 2020 at 22:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .