My setup

  • uname -a prints:

    Darwin Jutsu.local 11.2.0 Darwin Kernel Version 11.2.0: Tue Aug  9 20:54:00 PDT 2011;
    root:xnu-1699.24.8~1/RELEASE_X86_64 x86_64
  • Mac OS X Version: 10.7.3 as of this post
  • Processor: 2.66 GHz Intel Core i7
  • Memory: 8 GB 1067 MHz DDR3


Google chrome starts to time out in an odd way: I'll open a new tab and try to load gmail. It's taking longer then it should, so I try to right click or open the console but nothing happens.

I am able to close the tab and try again - but the page loads and I am unable to do anything on the page.


  • This is what things start to look like when life sucks...

    Processes: 97 total, 3 running, 2 stuck, 92 sleeping, 489 threads                                                                                                                                                                    11:59:12
    Load Avg: 3.35, 2.46, 1.58  CPU usage: 3.28% user, 27.93% sys, 68.77% idle   SharedLibs: 13M resident, 6744K data, 0B linkedit. MemRegions: 19003 total, 1363M resident, 65M private, 663M shared.
    PhysMem: 1037M wired, 2255M active, 272M inactive, 3563M used, 4626M free. VM: 198G vsize, 1118M framework vsize, 1886103(0) pageins, 0(0) pageouts. Networks: packets: 287068/334M in, 164599/24M out.
    Disks: 28824/1238M read, 56041/935M written.
  • I've tried to kill the processes -9 and -15.

    The processes end up as such: "(Google Chrome)" - which seems very odd to me. I'm used to seeing "Google Chrome He" or something like this:

    /Applications/Google Chrome.app/Contents/Versions/17.0.963.46/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --lang=en-US --force-fieldtest=ConnCountImpact/conn_count_6/ConnnectBackupJobs/ConnectBackupJobsEnabled/DnsImpact/default_enabled_prefetch/DnsParallelism/parallel_default/GlobalSdch/global_enable_sdch/IdleSktToImpact/idle_timeout_10/Instant/SilentExperimentA/Prefetch/ContentPrefetchPrerender1/PrerenderFromOmnibox/OmniboxPrerenderEnabled/PrerenderFromOmniboxHeuristic/ExactFullAlgorithm/ProxyConnectionImpact/proxy_connections_32/SpdyCwnd/cwndMin16/SpdyImpact/npn_with_spdy/WarmSocketImpact/warm_socket/ --extension-process --enable-print-preview --channel=313.0x33f8c00.1296777368

At this point I figure I should just restart or shutdown. But the system becomes unwilling to, stating that it can't shut down any of the current processes. I try to terminate Adium or the Terminal itself and those won't close as well.

This leads me to holding down the power button. 😳   When the system boots back up, everything works as it should, even the kill commands.

Does anyone have a guess as to what might be causing this?

Syslog: (220 was the parent Google Chrome process)

Feb 10 15:06:35 Jutsu Dock[222] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformsAtPlacement: Failed

Feb 10 15:06:35 Jutsu Dock[222] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformAtPlacement: Failed

--- last message repeated 1 time ---

Feb 10 15:06:35 Jutsu Dock[222] <Error>: kCGErrorIllegalArgument: CGSSetWindowListGlobalClipShape: Invalid window 0x72

Feb 10 15:06:31 Jutsu Dock[222] <Warning>: trying to take pid 220 out of fullscreen but it is not the current space


  • This problem is not exclusive to Google Chrome, it happens with iTunes and other applications as well.

  • "killing" the processes doesn't produce the desired results, but going to Apple Icon -> Force Quit does indeed completely stop the process as it should.

    But the system still begins to degrade in stability, for instance, iTunes reports:

    "The iTunes Library file is locked, on a locked disk,
    or you do not have write permission for this file."
  • When I tried to exit the Terminal that process became stuck as well (see report @ github).

Rebooting still remains the only viable option.😱 😰 😂 😭

  • What version of Mac OS X are you using, and what are your computer's specifications with regard to CPU, RAM the size of the hard drive, and available hard drive space?
    – user9290
    Feb 13, 2012 at 18:29
  • Updated the post at the top. Feb 13, 2012 at 19:32
  • Does ps auxr | head -5 show any process overtaking the CPU?
    – afragen
    Feb 13, 2012 at 22:08
  • I will wait for it to happen again and I will let you know. But if I remember the CPU usage was normal, load was good, but the processes in question were "stuck" but I'm sure there was more to it than that. Feb 13, 2012 at 22:24
  • → Grok: could you specify which graphical cards you have? Could you remember if this trouble is following a sleep of your Mac? At first, there is something holding the CPU within the Kernel (27.93%). I would suspect a kernel extension.
    – dan
    May 12, 2013 at 8:34

1 Answer 1


While your issue may go beyond this, there is one piece of behavior I've noticed with Google Chrome;

When you open a new window / tab, wait for the content to load. Wait for the Top Sites and everything else to appear. If you browse to a site while that's still loading, Chrome rarely allows me to browse to anything else. Wherein if I start having this problem and let the Top Sites content load, and THEN browse somewhere, it works pretty much perfectly and without any problems.

Whenever I'm "stuck" loading content, killing the tab takes time, at least a handful of seconds, but it does eventually happen.

However, I have never had massive computer instability as a result of Chrome, shutdown / restart has never failed to work.

  • I'm concerned since it was throwing Objective C errors. Feb 11, 2012 at 1:04
  • I have a ton of ObjC errors from Chrome in my Console, but I can't tell you any obviously functional problem they create. Feb 18, 2012 at 1:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .