0

I use a 4K monitor as my main monitor, with my laptop off to one side. Nearly every app I open opens correctly on the 4K monitor.

But Firefox always opens on the laptop monitor, even when its windows were on my 4K monitor when closed. Also, when I make a new window in Firefox, it opens on the laptop monitor (even when all existing Firefox windows are in the 4K monitor). Needless to say, this is very annoying.

How can I configure Firefox (or my Mac OS) to correctly open new windows on the 4K monitor like all other apps do?

This is on Mac OS 10.11.6 and Firefox 78.1.0esr.

10
  • 1
    Could you have a look at two settings & report back. 1. System prefs/Mission Control; is "Displays have separate Spaces" on or off? 2. Right click Firefox's icon in the dock & look in Options; what is set for Assign to? – Tetsujin Aug 20 '20 at 7:58
  • @Tetsujin "Displays have separate Spaces" is on, but there is no "Assign to" option at all. – Wildcard Aug 20 '20 at 15:06
  • 1
    The right click that gets you the options/assign to menu is there even if you only have one monitor/one desktop - it's just greyed out. This was just confirmed on Catalina. – Allan Aug 20 '20 at 16:58
  • 1
    OK, I just tested on El Cap & I agree… if you only have one Space you don't get that option. However… you have one Space, yet two displays with 'displays have separate Spaces' on. That's going to confuse the heck out of the machine. You have quite obviously two spaces, one per display… yet not enough actual defined Spaces to use them. Something's got to give somewhere. Either assign more Spaces [I'd suggest 3 minimum, display count +1] or remove the separate Spaces option. – Tetsujin Aug 20 '20 at 18:01
  • 1
    With only one Space, no - but the Mac will handle your dual-display single desktop differently. You will probably have to experiment to see which suits your workflow best, separate & more Spaces or not separate & just one Space. They give a different flavour to how your workflow behaves - no-one can decide which suits you best. [Personally on 2 displays I have many Spaces, all linked in pairs (separate off), but I never use fullscreen as that breaks everything for me.] – Tetsujin Aug 20 '20 at 18:51
1

It seems that the key setting to resolve this is "When switching to an application, switch to a Space with open windows for the application."

With that box CHECKED, new windows open where I expect them to.

Closing Firefox with two windows open both on my 4K display and then reopening Firefox, now reopens one window on the built-in display and one window on the 4K display, which is weird. I may post further updates if I figure out why or figure out how to resolve that. But having NEW windows open on my 4K display (as they now do) reduces the annoyance factor by a LOT.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .