Background: I need help troubleshooting this very bizarre bug that I can't figure out. This is on macOS 10.15.6 (before and after the most recent supplementary update) on a 2020 16" MBP. The only thing I could think of that changed right before this issue occurred is I was playing around with BitBar and some BitBar plugins, but the issue persists regardless of BitBar being running/quit or even BitBar being completely uninstalled.

The Bug: The Dock is gone, the process is not showing up in Activity Monitor, and it is unable to be restarted or even quit using killall Dock (shows up as a no matching process error). Additionally, CMD+TAB does not work, and the same permanently dead process is happening for Launchpad and Mission Control. Neither of them run when called from Spotlight, nor do they show up in activity monitor, nor can they be killed using killall.

Troubleshooting Thus Far: I've tried killall and some of the defaults write terminal commands floating around on the internet for killing/restarting these processes. I've tried poking around Activity Monitor for clues, and the Force Quit menu (relaunched Finder from there too just in case). I've rebooted, installed the most recent Catalina Supplementary Update, reset PRAM/NVRAM. I also cannot find anyone with the same issue anywhere on the internet, asked around on Reddit, and these are the closest I could find to my issue despite them not being the same and the solutions not working for me: SO1, SO2

  • First two simple tests - try Safe mode; try another account.
    – Tetsujin
    Aug 20, 2020 at 6:12
  • Could you please attach the crash logs? They can be find in /library/logs/diagnosticreports
    – Joy Jin
    Aug 20, 2020 at 6:23

1 Answer 1


Very Long Story Short

BitBar script for automatically changing desktop background somehow got run without my intent and set my desktop background image to a broken URL string. My desktop background was black so there was no visual change that alerted me to this being the culprit, but looking through ~/Library/Application Support/Dock/, I catted everything inside it just in case and turns out that desktoppicture.db was not gibberish but instead a URL.

This had the effect of keeping the Dock process stuck in limbo, where I could not kill or run it, nor could I actually witness it in any system diagnosis or crash report. It never crashed but it also wasn't running; a ghost.

  • You saved my life! This happened to me with the newly-released SwiftBar and I thought I was going to have to reinstall the OS. Thank you. Out of curiosity, do you happen to know if the rogue plugin in question was unlash-background.3h.sh? This is the only one I've got that appears to change the background, but running it again later, there were no issues. Dec 16, 2020 at 12:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .