I've a CalDigit TS3+ dock station with a DisplayPort external 1080p monitor, 100 baseT Ethernet, Apple USB extended keyboard (yes, wired USB keyboard) and Logitech UniFi receiver (for MX Master 2S) connected on it. It runs fine after upgrading to firmware ver 44.1, until system update 10.15.6.

This work station is set in my office and I'd take my MacBook Pro (personal property) home every day. So every morning I wake up my laptop and plug one single cable to it, then I can bring everything to work.

After updated to 10.15.6, USB 3.0 bus on CalDigits TS3+ are slow in response whenever plugging in. It would take about 5~10 seconds before the external keyboard/mouse set be responsive, and the situation is getting worse.

Since two weeks ago, the USB 3.0 bus on TS3+ stopped working completely when plug in TS3+ thunderbolt 3 cable. The hardware report from "About this Mac" shows that both USB 3.0 bus on TS3+ are not detected at all. But other peripherals, including DisplayPort display and Ethernet, they all work normally. And if I plug all my USB peripherals (keyboard, UniFi, iPhone, flash drive) directly onto MacBook Pro type-C ports, they will work normally, too. This situation can only be fixed by system reboot.

Furthermore: if I disconnect TS3+ from MacBook Pro when TS3+ USB bus going down, I'd get Kernel Panic after 10 seconds. And, this is very weird: there is no system crash log after rebooting from Kernel Panic. The system crash log in "Report to Apple" dialog is plain blank, and I could find nothing related to these KP events in Console.app. It's almost like "pull the power plug abruptly" on a desktop computer.

This situation does not happen every time but the rate is quite high, about 40% or so. And it needs not to have the laptop sleep overnight; sometimes I unplug my MacBook Pro for a meeting and reconnect after returning to my desk, and it will also trigger the problem.

I've tried to do NVRAM/SMC reset and, as expected, not working at all.

Can anyone give me advice ? I'd also considering replace the dock to a different model, but I'm not sure whether it's the problem of macOS or dock.

  • Seeing the same issues myself, Caldigit TS3+ Macbook Pro 16 Inch
    – NickKampe
    Commented Sep 24, 2020 at 18:29
  • 1
    @NickKampe funny, because CalDigit guys just insisted that no 16” owner had reported this. Read my answer for the ultimate solution.
    – RichardLiu
    Commented Sep 26, 2020 at 1:04

4 Answers 4


This may not be applicable however the bundled support and drivers for the TS3+ available at https://downloads.caldigit.com/ contain a kext called CalDigitThunderboltStationChargingSupport.kext found under /Library/Extensions/

This seemed to be the root cause of all my issues once this was removed I was able to restart & shutdown without issue for the past 4 weeks without issue.

the documented removal process can be found at https://archive.caldigit.com/KB/index.asp?KBID=142&viewlocale=1

If you have installed this it may be the cause of your issues.

I have held off responding until I had a significant amount of time without the issue re-occouring before commenting.

  • They updated this driver in February, I wonder if it fixed this issue. I had stopped using the dock for a while, I started again and am no longer having an issue (over the past few days), not sure if it was fixed by Big Sur updates or the new version of this extension.
    – xxxxxxxxx
    Commented Mar 27, 2021 at 9:45
  • Really can't comment, a fresh wipe and install and resolved the issue fully,I feel that the tool provided to firmware update the dock to deliver more power is the root cause. For relative data points the company I work for deploys around 1200 of these docks and I can see all the crash logs on affected devices and I have only found crashes on macOS devices which have it installed, to the point we ban it in the estate. My running thought is it's only really 16" power users who do this install hence they're affected most people just use it out of the box plug and play without issue.
    – Setsquared
    Commented Mar 28, 2021 at 13:22

CalDigit guys confirmed this issue and apparently they’ve no idea what’s going on. They insisted that this only happens to MacBook Pro 13” 2020 as they have “never received report from 16-inch owner”, and they “believe” this will be fixed in Big Sur.

So I dumped this junk and get a Targus dock, and happy ever after.

  • This is trash. I just started having this issue in the last month, usually related to trying to use the card reader (I'm waiting for my monitor to be sent from overseas so I haven't been using it as a USB hub much, since I'm not set up at a desk like normal).
    – xxxxxxxxx
    Commented Oct 10, 2020 at 13:40
  • @Morgan Rodgers: TS3+ built-in card reader and audio output are attached to its USB bus by default, so it doesn’t really matter whether you connect other USB device to it or not. When it goes rogue, the whole USB bus will be undetectable by system, so card reader, audio and external USB devices will cease to work at the same time.
    – RichardLiu
    Commented Oct 12, 2020 at 10:00
  • Yeah I know, was just mentioning the port I've been having issues with. I haven't been using it in the last few months for other USB peripherals since I haven't been set up at a desk, but it's my only card reader. I definitely realize it's the same issue.
    – xxxxxxxxx
    Commented Oct 12, 2020 at 10:26

Well, I'll add my 2019 Macbook Pro 15 to the list of non-2020 13" models experiencing the "kernel panic". All of my essential extensions are blocked if I attempt to boot up with the TS3+ plugged into my laptop, if it boots at all. Most often, even if I plug it in AFTER a successful boot, it immediately triggers a restart that sends me to the decidedly dead link "support.apple.com/startup" for assistance. I can't get my system to bootup at all, and I too have experienced intermittent boot passes that immediately launch a stack of "extension blocked" error windows along with the "kernel panic" warning.

I'm running the latest TS3+ firmware, that was released for Catalina to support 87W charging. If they needed to flash new firmware for Catalina, not exactly sure why they're dumbfounded by this issue if they haven't fully tested the Catalina firmware for Big Sur--especially since Big Sur has substantially retooled architecture compared to its predecessor.

This needs to be addressed by CalDigit. They clearly need to update their firmware, because otherwise my computer functions absolutely fine.

  • Funny because CalDigit guys blamed Catalina for all the problems, and treat Big Sur as the messiah that should miraculously save everyone’s ass from kernel panic hell. Guess they’re now asking their victims to wait for 11.1, whatever landscape name it is.
    – RichardLiu
    Commented Nov 29, 2020 at 0:44
  • What about the OWC Thunderbolt Docks? Are they known to cause kernel panics as well?
    – odysseus
    Commented Dec 4, 2020 at 14:57

After I installed Ventura my mac went from the occasional Kernel Panic to crashes all the time when dual monitors are plugged in via the TS3+, and just switching the monitors on or off was a lottery: it might crash, freeze for a few minutes, or be fine.

What fixed it for me was deleting the Colour profiles:

Entirely clear this folder:


Wipe this file (the * is a long random hex string):

  1. Shut down the computer & restart.
  2. Profit

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .