I tried installing Imagemagick using 'brew install imagemagick'. The end result I was hoping for was the existence of commands mogrify and convert. It had apparently been a long time since I ran Homebrew; tt thought for a long time and then went about updating a positively frightening number of packages. It ran for perhaps 45 minutes, and I really have no idea how much it updated. Dozens, scores, perhaps hundreds of packages. Including Ruby and Python, which was pretty scary in its own right.

After all that time Homebrew reported failure because something it was trying to instlal required a later version of Xcode than was installed. It turns out that the version it wanted was part of Catalina, and my OS is still at Mojave, so I can't upgrade Xcode to satisfy Homebrew.

When all was done, the mogrify command exists and works but the convert command is nowhere to be found.

I have tried redoing 'brew install imagemagick' -- it says the package is already installed and refuses to do anything. 'brew upgrade imagemagick' worked once but there is still no convert command to be found.

Do I have to uninstall and start over?

  • Start with brew doctor and fix any issues it reports.
    – nohillside
    Aug 20, 2020 at 5:48
  • Thanks, forgot to mention I did that.
    – kdawson
    Aug 21, 2020 at 11:47
  • I assume you resolved all issues brew doctor reported then. What is in /usr/local/Cellar/imagemagick/*/bin?
    – nohillside
    Aug 21, 2020 at 12:47

2 Answers 2


Think I resolved the problem. convert is present in /usr/local/Cellar/imagemagick/7.0.10-28/bin as a symlink to magick; which led me to look in /usr/local/bin where mogrify exists as a symlink; convertis present there too. Running rehash (hash -r) brought it into visibility on the path.


In v7 ImageMagick all the original commands are removed, i.e. convert, mogrify, compare, stream, identify...

I believe this was done for two reasons:

  • to avoid eternal problems of ImageMagick convert clashing with Microsoft's CONVERT.EXE which converts filesystems to NTFS, and
  • to decrease "namespace pollution" by putting all ImageMagick commands under a single magick invocation.

As such, you shouldn't be using convert or mogrify going forward.

This command:




And this command:

mogrify -resize 100x100 *.png


magick mogrify -resize 100x100 *.png

More detailed information available here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .