0

When I first log in to my mac, the bottom of the finder window shows 28.7 GB available

As soon as I interact with the finder, that changes to 417.35 GB available

About this mac > Storage shows 417.35GB out of 751.07GB

However, in the terminal df shows:

Filesystem    512-blocks       Used Available Capacity iused               ifree %iused  Mounted on
/dev/disk1s1  1466930136 1408631896  54750856    97% 2915208 9223372036851860599    0%   
devfs                368        368         0   100%     638                   0  100%   /dev
/dev/disk1s4  1466930136    2097200  54750856     4%       1 9223372036854775806    0%   
/private/var/vm
map -hosts             0          0         0   100%       0                   0  100%   /net
map auto_home          0          0         0   100%       0                   0  100%   /home
/dev/disk0s1      403218      25912    377306     7%       0                   0  100%   
/Volumes/firmwaresyncd.UxqR5T

Omnisweeper shows 28.7 GB free, 720.6 GB used, 751.1 GB total

When I am working with certain applications in the terminal, I get errors/warnings about disk space being too low...

I tried booting into safe mode, and the progress bar got to 95% and sat there for... 20 minutes.. I eventually gave up trying to boot into safe mode.

Is there anything I can do to solve this other than formatting my drive and starting over?

I am running Mojave 10.14.3 (18D109) on a mac pro Retina, 13-inch, Late 2012.

4
  • Safe mode does some extensive disk checking on boot. If I were you I would boot into recovery mode (COMMAND-r) run disk utility and run a repair on your disk(s). Let it run overnight if you have to. You may have a disk error. Aug 19 '20 at 23:56
  • @SteveChambers I just ran disk utility and it went through 22 snapshots, said the volume was ok... But disk utility showed 28 gb free, 28 gb available (0 purgeable)... Strangely when I run Disk Utility from my user account in non-recovery mode, it says 28.05 gb free, 417.05 gb available (389 gb purgeable).
    – patrick
    Aug 20 '20 at 2:45
  • While attempted to learn about "purgeable", what I saw was it is related to iCloud optimized storage--- except I have never used iCloud, and do not have it enabled. I tried enabling just to see-- and it says 0kb of 5gb user, and there is no "optimize storage" option as the articles I read described, so I assume that was from an older version of mac OS.
    – patrick
    Aug 20 '20 at 2:59
  • In the future, try tmutil listlocalsnapshots / , and if there is a whole bunch of them, tmutil thinlocalsnapshots / 9999999999999 4
    – Joy Jin
    Sep 20 '20 at 4:09
1

My solution was to create a 415GB file and then delete it. Now everything is working fine.

1
  • did you just use touch or did you actually have a 415 GB file?
    – Natsfan
    Sep 19 '20 at 21:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .