1

I am trying to run the gatsby-cli on a fresh install of macOS.

I downloaded npm and node from https:node.js.org/en.

Then installed the packages.

Then installed npm i -g gatsby-cl.

However, when I try to run a command like gatsby build I get a string of errors like

"libpangoft2-1.0.0.dylib" cannot be opened because the developer cannot be verified.

I got into System Preferences > Security & Privacy > Allow Anyway but the execution sequence stops and the Allow command is not saved.

How to I grant permissions to these executables so I can run gatsby commands without the popups?

5
  • Have you tried sudo gatsby build? Also, you can try getting Node and NPM from HomeBrew although I'm not sure that it would make much of a difference. – Todd Aug 18 '20 at 14:00
  • sudo gatsby build throws the same error. I was hesitant to install via Homebrew because I don't know how to uninstall the current version of node/npm. – Matthew Aug 18 '20 at 14:07
  • You can search your computer for uninstaller or see if Homebrew overwrites the current Installation. I have no problems with my installation of NPM using Homebrew. What version of macOS are you using? – Todd Aug 18 '20 at 14:35
  • I found a tutorial on Stack Exchange for a manual uninstall, not sure if I got it all. I reinstalled with Homebrew and am getting the same error sequence. – Matthew Aug 18 '20 at 14:56
  • It seems to be more related to running the cli than node itself. – Matthew Aug 18 '20 at 14:56
1

Adding Terminal permissions in System Preferences > Security & Privacy > Privacy corrects this issue.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .