2

I just acquired a mid-2014 Macbook Pro that's been reconditioned. It booted up in El Capitan, so my first order of business after the initial sign-in and setup was to attempt to upgrade the OS to Mojave, or less preferably, to Catalina. Mojave first because some of my audio software still uses a few 32 bit plugins which have not as yet been up-written to 64 bit.

The problem: When I go to the app store (via any path, internal or external) signed in to the Store or not, and click the Download button for either Mojave or Catalina, no download happens. For Mojave, the Download button changes to dark grey and says "Downloading", the 'spinner' spins for 20 seconds and stops. A status bar underneath shows the progress dot stuck at the beginning, with no movement, even overnight. For Catalina, the Download button changes to dark grey, but still says "Download", not "Downloading", the 'spinner' spins for four seconds and disappears, but no progress bar is displayed, and nothing else happens, at least not within the coming hour.

Here's the catch: downloads of other apps from the Store to this machine work normally, as evidenced by my quick and successful downloads of Battery Health 2, and an attempt at downloading LastPass password manager (which I then declined until the OS is upgraded - but it was ready to work.)

What have I tried..? Sign out of Store, close Store, reboot computer, sign back in to Store, try again. Did this with sequence variations several times. Tested using two external page links direct to the Store's Mojave and Catalina pages, same result. Copy-pasted a forum-suggested line of code into Terminal to reset the Store, but system rejected part of the code as an unknown reference. Have read every forum suggestion I can find on this, but none of the previous questions or answers seem to address this situation exactly, in that only the OS downloads won't start, but others are okay.

According to the applications chart this Mid-2014 Macbook Pro is clearly eligible for all OS up through Catalina. My two other Mac computers on this network (one also running El Capitan) interact normally with the Store.

Suggestions? Thanks.

2
1

We do this all the time. Here is a quick process.

When this doesn’t work, it’s almost always the network so take your Mac to a new location (public library, school, different ISP) or have a friend download the installer and make them a pie or meal in thanks.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .