I had recently backed up my phone (iPhone 6+), and had to restore it since it was playing up, and when the phone turned on, I was greeted with the 'Press home to upgrade' screen. I had my assistive touch on the top of the screen, tried to press it but it didn't respond. I tried factory resetting it through iTunes, but iTunes requires me to input the password, which I can't really do. I can't put the phone into recovery, because as I previously mentioned, the home button is broken.

What can I do to get my phone back?

  • Why can't you input the password? Aug 15, 2020 at 0:55
  • 2
    It's stuck on the 'Press home to upgrade screen', and unless you press the home button you can't input the password. In my case I can't get past said screen since the home button is broken and my assistive touch isn't working for some reason :/
    – CatRass
    Aug 15, 2020 at 1:08
  • See if this help: apple.stackexchange.com/q/284345/119271. However, you need to get the button fixed - bodging things is good in a pinch, but you’re going to end up having issues as you progress
    – Allan
    Aug 15, 2020 at 4:42


You must log in to answer this question.

Browse other questions tagged .