3

Upon running Disk Utility against `Macintosh HD - Data", I get the following towards the end of the check:

error: dstream (id 8753874978) does not have an associated dstream id object
Verifying allocated space.
Performing deferred repairs.
error: Unable to perform deferred repairs without full space verification
error: Try running fsck against the entire APFS container instead of a volume
The volume /dev/rdisk1s1 could not be verified completely.
File system check exit code is 0.
Restoring the original state found as mounted.

I've booted into Single User mode, but running fsck -fy tells me that it cannot be run because the /dev/rdisk1s1 drive is mounted in write mode. I've also tried Googling the term "error: Unable to perform deferred repairs without full space verification" and found 1 thread on Apple's forums, with 67 likes and 0 answers.

So, how can I repair my HD? rMBP late 2013 model.

8
  • Why are you using single user mode rather than Recovery?
    – Tetsujin
    Commented Aug 13, 2020 at 9:51
  • Because that what has always worked for me when Recovery Disk Utility didn’t solve the errors.
    – zerohedge
    Commented Aug 13, 2020 at 9:52
  • 1
    single user is booted from the partition you are trying to repair, recovery isn't.
    – Tetsujin
    Commented Aug 13, 2020 at 9:53
  • OK. I’ll be happy to upvote any answers that solve this.
    – zerohedge
    Commented Aug 13, 2020 at 9:56
  • If you try my suggestion & report back, I'll be happy to...
    – Tetsujin
    Commented Aug 13, 2020 at 16:37

1 Answer 1

4

Run Disk Utility in Recovery Mode:

  1. Boot into Recovery mode by holding down ⌘R while powering up
  2. Select Disk Utility
  3. Select the "Container" for Macintosh HD - Data (do not select Macintosh HD - Data itself)
  4. Click "First Aid" and "Run"
  5. If that does not seem to fix the problem, select the Drive that contains the "Container" and run "First Aid" on it.

The above is from memory. You may need to mount or unlock the drive at some point in the above process.

1
  • 3
    At least in Monterey, In order to select the container for Macintosh HD, you'll need to pick View -> Show All Devices or press command-2. The container for your main drive isn't shown by default.
    – adiabatic
    Commented Nov 26, 2022 at 21:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .