0

When using cmd + shift + 5 to screen record, there is only one option present for sound (Macbook Pro microphone). This captures the 'computer' audio, but it also records unwanted noise in the physical environment.

To reduce/remove the background noise, I've tried:

  • System Preferences -> Sound -> Input -> MacBook Pro Microphone -> Input volume to zero. This does indeed prevent background noise from the microphone being recorded, but also causes the screen recording to record without any audio, that is, it fails to capture the 'computer audio' (for lack of a better term)
  • Opening Audio MIDI Setup -> MacBook Pro Microphone -> 'Mute'. But this has the same effect as the previous attempt (no sound from the microphone, but also no sound from the computer).
  • As a temporary fix, searching for where the microphone is in the hope of placing something physical over it.

Is there any way to disable the microphone entirely so the 'computer' audio records but without any background noise?

3
  • 1
    You have to create a loopback interface where audio goes from output directly back to an input. This way, you can capture only the audio thats made by the computer and nothing captured by the mic. It’s described in the dupe link. – Allan Aug 13 '20 at 4:25
  • Thanks @Tetsujin I am slowly working my way through those solutions. The one I tried so far doesn't work, but hopefully at least one will. I will report back! Thank you again – stevec Aug 13 '20 at 9:38
  • @Allan thanks! That's a very creative solution! I will try to to find a software solution (hopefully a free one) and if I have no luck will take the hardware / paid route. I hope it becomes an available option in the future so third party software/hardware isn't required. – stevec Aug 13 '20 at 9:42
1

Before you begin to record, go to System Preferences > Sound > Input. Make sure the input source selected is "Internal Microphone." Then move the slider ("Input Volume") to the left to reduce the input volume.

3
  • Thanks! I just gave it a try and it does eliminate the ambient noise from the physical world, but the computer audio also vanishes (i.e. the screen capture has no sound at all). – stevec Aug 13 '20 at 1:58
  • 1
    Sorry it doesn't work for the internal inputs. I hope you can find a solution. – DavidSupportsMonica Aug 13 '20 at 2:08
  • Thanks all the same! – stevec Aug 13 '20 at 2:09
1

Could you screen record using QuickTime? There's an option in QuickTime to screen record and use an external microphone (i.e. not the MacBook internal mic). Just open QuickTime and click in the menubar File > New Screen Recording. Then when the screen recording dialog box appears, you can click on the drop down menu next to the record button and select record with an external microphone. See image below.

Hope this helps enter image description here

1
  • Thanks! when I attempt this, the three options I see are i) Microphone (greyed out), ii) None, and iii) MacBook Pro Microphone. I don't own any external microphone so there's no option for that. (and even if there was, wouldn't it still record it's sound, which is undesired here?) – stevec Aug 13 '20 at 6:48

Not the answer you're looking for? Browse other questions tagged .