Edit: I did a factory reset and it worked. Very annoying bug...

I haven‘t been able to update apps in months. Whenever I click on update, the App Store prompts me with:

“If you have an Apple ID, sign in with it here.“

Not only am I already logged into my account (yes, it is the same account that I used to download the app), there is literally no way I can log in with this prompt, since it asks for only a password and not an email + password. Whatever I type in, I get “Your Apple Id or Password is incorrect.“

Here‘s what I‘ve tried:

  • Updating iOS

  • Restarting iPhone several times

  • Logging in and out of different Apple Accounts

Does anyone have any ideas on what I should do? Anything I’m missing?

I haven‘t really cared much but now WhatsApp is forcing me to update and refuses to support my version so I literally cannot use it. I also don‘t want to delete and reinstall it because I would lose my chat and document histories.

  • Welcome to Ask Different :) Did you consider backing up your iPhone and performing a device reset? I agree it would be a hassle but if nothing else worked it would be worth trying, and you can also backup your device to a computer/iCloud and would not lose data.
    – Nimesh Neema
    Aug 12, 2020 at 21:15
  • 1
    Is it possible the app was purchased (/downloaded) under a different Apple ID? Aug 13, 2020 at 0:07
  • Not sure what's happening, but if you can download apps from the app store (but not update them), maybe you can try deleting the app and reinstalling it from the app store. Don't do this if you can't download any apps at all. I'd also check that you don't have any outstanding account charges that you haven't paid using your credit cards, because it may ask you to update your billing details before letting you continue on the app store.
    – AVelj
    Aug 13, 2020 at 2:41
  • @GordonDavisson: Thanks, that was the problem in my case. App was installed when my wife used the phone. Should have done a factory reset when I started using it instead of just changing AppleIDs, as I keep running into weird stuff like this.
    – pavon
    Dec 18, 2020 at 1:36

3 Answers 3


To anyone having the same problem, the only thing that worked for me was doing a full reset.


in my case issue was happening because some softwares were downloaded from one Apple Id and I was trying to update the same software from other Apple id. Issue got resolved when I logged into Appstore with previous Apple Id.


Why don't you try setting automatic App updates? Then your apps will automatically update in the background. Go to settings and tap on iTunes & App Store in the panel on the left. A new panel opens on the right. Near the top of this panel, you'll see Automatic Updates. Under that are 4 options the last of which is App Updates. Turn the slider switch on. Now your app updates should load automatically.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .