2

If I change the tracking speed of my USB mouse then literally nothing happens. It tracks at the exact same speed:

tracking speed

It appears to remember the setting and it makes defaults read -g com.apple.mouse.scaling return different results, but the actual mouse tracking speed never changes. Is there any way to debug this? I'm using MacOS 10.15.6.

1
  • Have you rebooted the computer? Have you rebooted the computer into Safe Mode and tried it there? Have you tried a different mouse? Commented Aug 12, 2020 at 14:50

1 Answer 1

1

Ah I just figured it out! I was using a KVM with a "fast switching mode" where you can hit the side of the screen with your mouse twice to switch inputs. Somehow this got turned on. (It also explains why it was randomly switching inputs without me asking!)

As soon as you turn it off (Scroll lock, Scroll lock, F12 for the one I'm using), the mouse works perfectly again. My guess is that in order to know when you hit the side of the screen, the KVM has to be in charge of the position of the cursor on the screen, so it must set the mouse to absolute mode, and then the OS sensitivity has no effect.

Would be nice if something in the UI said the mouse is operating in absolute mode (I didn't even know that was possible, though I guess graphics tablets use it).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .