I am unable to copy movies or videos into my iTunes library. I have had the concerned videos converted using Handbrake (version ??) with Apple presets but still when I try drag and drop to iTunes (10.1 on Windows XP) it shows no error (like "cannot be played" etc) and neither does it show up on the list.

I can copy songs/ebooks/apps got a problem with video only.

So I updated to iTunes v 10.5.3 still can't drag drop video/movies. I even tried adding the files to the Automatically add to iTunes folder (as suggested in one of the comments) but got a Not Added folder. The files work when copied to the library on a friend's, so I can't tell if the problem is iTunes or Windows XP or my computer.

Am I missing something?

  • 2
    Hi, welcome to Ask Different. Before anyone can answer authoritatively, can you clarify exactly what the error message is, and what format you are encoding in with handbrake?
    – stuffe
    Feb 10, 2012 at 9:49
  • @stuffe I used the built in preset for iphone 4 and i get no error message at all, i try drag and drop and nothing more, no messages at all (atlest cannot be played in iphone would have been heartening) and these presets
    – NewBee
    Feb 10, 2012 at 10:35
  • So the real problem is getting them into iTunes in the first place? Try the following: 1) can you play the resulting file without importing to iTunes, just double click open it? 2) Check the filename is .m4v not .mp4, iTunes prefers it. 3) Update iTunes to the latest version (cop out, but might help) 4) reset your presets in handbrake, you may have modified one. Or try Apple Universal too. I can't really put this as an answer as I'm just guessing right now :)
    – stuffe
    Feb 10, 2012 at 10:44
  • @stuffe Right i am not able to get them into iTunes,can play the file, the extension is right and i have tried with all the presets. Could give a try by updating iTunes to the latest !. Do you have any idea as why is it not giving any error if it can't move it to iTunes library maybe i overlooked something.
    – NewBee
    Feb 10, 2012 at 10:51
  • I can only guess that there is a problem with your iTunes library database files. You can test this. Hold down SHIFT and start iTunes. It should ask you to create a new library - don't worry, this is in addition to your existing one. Try creating a new one and putting your files in there
    – stuffe
    Feb 10, 2012 at 10:55

1 Answer 1


I have been facing the same problem with iTunes (both 10.5 and 11). You need to upgrade to iTunes version 10.5 or 11, and you would need Quick Time to play older media or videos.

  • 2
    It's a bit confusing since you say the problem exists with v11 but the OP should upgrade to version 11. Perhaps you can explain more about reinstalling QuickTime or some other test to help people in this case?
    – bmike
    Dec 12, 2012 at 14:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .