1

I want to set the zoom level in TextEdit to a precise value so that the on-screen display has the same size as the printout. The "Zoom in" and "Zoom out" controls are too coarse for this.

2 Answers 2

1

The following workaround does at least provide a fixed user-settable zoom (TextEdit 1.13, OS X 10.13.6 [High Sierra]).

  • Create and save a blank TextEdit doc (maybe make it Stationery via Finder Info)
  • Open the doc in TextEdit (don't use "Open Recent") and select the Option button to "ignore rich text commands". (Or, open it in some text editor which doesn't do RTF.)
  • Add the command \viewscaleNNN in the header material; or, preferably, the command string \margl1440\margr1440\vieww16140\viewh20440\viewkind1\viewscale140

This does the following: set the left margin to 1 inch (1440 units, whatever they are), the right margin similarly, the window width and height to big enough that the doc will open showing a full page (otherwise you get the middle of the page but not the edges), the "viewkind" command (use 1 as shown for Page Layout view, called "Wrap to Page" in TextEdit), and finally the viewscaleNNN command, with "NNN" here being "140" setting the zoom to 140%, which is what is needed on my particular setup; experiment to find the percentage you like. These and many more RTF commands may be found here.

  • Finally, save the doc and use it as stationery.
1
  • Re-posting my original misformatted "question" as an actual question and answer. I hope this passes muster as being on-topic. Commented Aug 6, 2020 at 1:47
0

TextEdit (and most other Apple apps, like Pages, etc) has an "Actual Size" menu item in the View menu.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .