3

I realized a few days ago that my spotlight wasn't finding any files. It was only giving me dictionary definitions and siri website suggestions. I figured it needed re-indexing so I tried adding the relevant volumes and folders to the Privacy list in Spotlight System Preferences but whenever I tried to add them I got the message

Privacy List Error

The item couldn’t be added or removed because of an unknown error.

I've tried everything suggested here: Spotlight doesn't show applications

I DID have Paragon NTFS for mac installed and working and apparently there are some contradictions there so I manually removed it completely. The only thing that worked, for a fleeting minute or two was force quitting SystemUIServer From activity monitor. Things moved quite slowly but it actually did find some files and I had the "Show all in finder" option at the bottom of Spotlight.

Another symptom is when I open an installer, even a simple, small one, the first step I get the spinning wheel of death, before it then doesn't find Macintosh HD to install onto. Also, not sure if it's relevant, but for some reason my RME Fireface 400 stopped being recognized by my computer (connected via firewire 400 to 800, to thunderbolt 2, to USB-C but it was never a problem before). I am using bootcamp to also have Windows 10.

I've also been having crazy trouble with Google Chrome after accidentally downloading some malware.

Any help would be greatly appreciated. My macbook pro is only a few months old. It's a 2019 Macbook Pro with OS 10.15.5 Catalina.

Thanks,

Alex

1
  • Having the same trouble, Alex, also in Catalina, and hoping you found the fix. Mine began after using Carbon Copy Cloner and I've read it's happened to many others.
    – Pamelane
    Feb 10, 2023 at 5:11

1 Answer 1

1

I know it's over 3 years late but I'm just leaving this possible solution here in case anyone else stumbles across this super specific issue (I also uninstalled paragon's NTFS for mac on macOS catalina and had my spotlight search break to the point where a full os reinstall didn't fix it).

The solution: I just went to activity monitor and searched for 'ntfs', and killed the one remaining process. Immediately after that, spotlight started working normally again and I could find my files as expected. (not sure if it persists through restarts; I haven't tested it yet. but now that everything works fine, you can reinstall and immediately uninstall ntfs for mac with the proper uninstaller, which is a permanent fix.)

When removing the NTFS for mac software, I just haphazardly deleted most of it, leaving bits of it strewn around the OS. This makes me believe the problem probably could have been avoided altogether by using the uninstaller bundled with the NTFS software, but oh well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .