2

An example of what should be there. When trying to install VMWare in MacOS Catalina, under security and privacy system preferences and then general, I do not see a way to allow what it needs to work properly. Even when I unlock the system preferences, it does not give me an option to allow in order to complete the setup. I also recently tried installing parallels desktop, which requires the same procedure in system preferences, and I was not able to get that working properly either because the allow button is not there. Anyone know why this might be? Thanks so much for the help!

1

That's because it's not meeting the guidelines for the possible install sources.

Now, the remainder of this answer is going to assume you're a legitimate user of the box with Admin permissions (or access to an admin account on the box):

Easiest fix: when you launch the installer, hold down the option key. That should offer you a prompt to override the security restrictions.

More permanent, global fix: Launch your terminal, and enter the following:

sudo spctl --master-disable

This will provide you henceforth the ability to install untrusted app (read: not notarized by Apple) from any source.

Running

sudo spctl --master-enable

will reverse the process.

0

You can manually add consent for kernel extension:

  1. Go to recovery mode (holding down the Command and R key during start)
  2. In terminal, type: spctl kext-consent add EG7KH642X6
  3. Reboot

EG7KH642X6 is the team id for VMWare. You can get this when installing .pkg files. There should be a lock on top right of the window during installation. Clicking it will show the information.

0

The first step is to locate the extension in your system.

Usually I look at the following path:

/Library/Extensions

You should be able to find a .kext file with the.

You can then proceed to load it again using:

sudo kextload `path`

And then if you reopen Security under System Preferences you should be able to see the Allow button now.

M1 and Intel support

One extra thing:

I recently tried to install a kext which resulted in the following error:

Incompatible architecture: Binary is for x86_64, but needed arch arm64e

If you are running M1 and see this, that is because the binary is for Intel computers only.

-2

The single "Allow" button on the "General" tab is for unsigned software. VMware is signed so you do not need to "Allow" it there.

Under Catalina, there is a list of privileges that can be granted under the "Privacy" tab, and for VMware you need to enable "Full Disk Access" there.

Click on Privacy and then "Full Disk Access" on the left, unlock the panel, and check VMware in the list on the right.

Privacy tab

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .