1

I’ve a 525 GB Crucial SSD that I can’t mount. It appears only greyed out on Disk Utility but not in Finder or Desktop.

Here's the disk description by diskutil list

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *525.1 GB   disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS SSD500                  524.1 GB   disk2s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk2s3

diskutil verifyDisk /dev/disk2 and diskutil repairDisk /dev/disk2 say The partition map appears to be OK

  1. I tried to mount the disk with diskutil mount /dev/disk2 but I got Volume on disk2 timed out waiting to mount

  2. I tried using diskutil mount readOnly /dev/disk2 but I also got Volume on disk2 timed out waiting to mount

  3. I tried to force mount the disk with a specific filesystem using mount force -t Apple_HFS /dev/disk2 but nothing.

At the end I wrote diskutil repairVolume /dev/disk2 but I got this error that I didn't know:

Error starting file system repair for disk2: Invalid request (-69886)

Here's a gpt output from sudo gpt -r show /dev/disk2 if needed:

start        size  index  contents
           0           1         PMBR
           1           1         Pri GPT header
           2          32         Pri GPT table
          34           6         
          40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
      409640  1023669408      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  1024079048      262144         
  1024341192     1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  1025610728           7         
  1025610735          32         Sec GPT table
  1025610767           1         Sec GPT header

There're some alphanumeric codes wrongs? What could I do?

I think that the problem is on the disk2s2 Volume (Apple_HFS SSD500)..maybe enter in Safe Mode and use fsck could be useful? Thanks in advance.

7
  • Which computer do you have and which version of the system software are you running?
    – Natsfan
    Commented Aug 1, 2020 at 17:46
  • @jmh I've a MacBook Unibody Mid 2010 (MacBook7,1) running macOS High Sierra 10.13.6 with SIP enabled
    – Bug-Gy
    Commented Aug 1, 2020 at 18:38
  • @Allan The disk is not mine and unfortunately there's not a TM Backup..before recover data with DataRescue or similar I would like to try to restore the disk if it's possible
    – Bug-Gy
    Commented Aug 1, 2020 at 18:41
  • Yes, or at least make it visible from Finder so I can recover many data as possible, or I'm hopeless?
    – Bug-Gy
    Commented Aug 1, 2020 at 18:44
  • Ok understand, for you can I at least recover data with some dedicated programs?
    – Bug-Gy
    Commented Aug 1, 2020 at 18:59

1 Answer 1

0

A "time out" means that a command was sent and the system is waiting for a response but didn't get one. Instead of waiting forever, a period of time is hard coded into the utility (diskutil) to wait and once it's reached, it generates the error.

Also, when you see "invalid request" as a response from your disk it means that the controller didn't understand what was supposed to be very much valid. These two conditions are indicative of a failing (or failed) hardware.

If you have a failing component like the SATA controller on the drive (it's what bridges the SATA interface on the logic board to memory modules in the SSD), you'll never get it working. It may be intermittent where it works for a while but then fails again. It's like having transmission where all gears but one have some broken teeth on them. You can change the fluid all you want and reprogram the transmission computer, but it won't fix the broken part(s). You might get it working (the unbroken teeth on the gears line up), but hardware failures are pretty much permanent; it'll fail again.

What will happen is you'll have a nice clean "fixed" drive ready to fail at the worst moment. It's better to just spend the $40-60USD and get a new drive and have the piece of mind your data is not at risk.

Possible Recovery

You might still be able to recover the data, but I don't advise doing it on the device itself. Instead, make an image of the drive and work off of that. You will need:

  • A working MacBook that one with a new SSD and clean install is fine. You can also use a friends. One that you can leave alone for a while to do recovery operations

  • A USB3 to SATA cable. This will allow you interface with the drive without having to open up a Mac to connect it to the SATA bus. Ideally, you want USB3 for the higher transfer speeds. You can use USB2, but it will take considerably longer.

  • Recovery Software like DiskDrill (I've used this personally with very good success) or Disk Warrior (other have reported success). The diagnostic features of these utilities are free so you can use them to see if the data is recoverable. If you want to recover the data, you can purchase a license key that will unlock it. If you're data isn't recoverable then you're not out any money.

You want to work on an image instead of the device itself. Stressing out the drive can only compound the problem. It's like our transmission with broken teeth on the gears - continuing to run it will only make it worse, not better. Same with electronic components - there may be no more spinning drives, but passing electric current, which generates heat through failing components isn't doing them any favors.

You can use the built-in dd command to make an image.

$ sudo dd if=rdiskX of=/path/to/disk.img bs=4M

This will make an image of your drive wherever you decide to put it (i.e. your Desktop - ~/Destktop/disk.image). Then run your recovery software on the image. Note: This is a "set it and forget it" type of operation so, it's going to take some time. But, once you have the file, you'll be able to copy it and move it and do your operations on it without running the risk of further data loss.

5
  • Great, my Mac is quite old and I've only USB2 port so it will take a while..also I'm using this USB enclosure to connect my SDD to pc, its good or I need a cable as you suggested?
    – Bug-Gy
    Commented Aug 1, 2020 at 19:47
  • That enclosure is perfectly fine. I just recommend the cable because there's nothing to open ;-)
    – Allan
    Commented Aug 1, 2020 at 19:48
  • Using sudo dd if=/dev/rdisk2 of=~/Desktop/disk.img bs=4m got this output: dd: /dev/rdisk2: Device not configured 156+0 records in 156+0 records out 654311424 bytes transferred in 47.096872 secs (13892885 bytes/sec) Practically I've recovered about 625 MB only..
    – Bug-Gy
    Commented Aug 2, 2020 at 12:29
  • Unfortunately, it means that SSD can’t be read.
    – Allan
    Commented Aug 2, 2020 at 16:27
  • Ok, thank you anyway for your help.
    – Bug-Gy
    Commented Aug 3, 2020 at 9:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .