0

I had a crash of my Mac right in the middle of saving a Pages document I was working on. It turned out that SSD broke. I had the computer repaired, the SSD replaced, and I have also recovered the entire computer from my last Time Machine backup (which had a previous version of the critical file, of course, backed up a day before the crash).

And everything seems to be fine, except that I cannot open the very same Pages document: when I try to open it, Pages gets stuck in the "Opening ..." dialog, showing the progress bar fully filled (100%). In addition, Finder has a difficulty showing the preview of that file - it display the contents with a very, very long delay (minutes).

I tried to remove the ...com.apple.iWork.Pages.savedState directory, as suggested in another answer, without success.

2
  • Have you tried making a copy of the file and then opening the duplicate? – Natsfan Jul 31 '20 at 16:15
  • Yes, I did (before finally solving the problem different way), and it didn't work. Thanks anyway. – Dragan Milicev Jul 31 '20 at 16:39
0

Just solved the issue by updating Pages to the newest version! Thaks and excuse to everybody.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .