1

I'm running macOS High Sierra on early-2015 Macbook Pro.

I used to have two more partitions: one with Bootcamp, and the other one as a shared FAT32 folder.

As far as I remember, at some point I made the mistake of using something other than Disk Utility to manage my partitions. I messed up GUIDs but I fixed them manually later, and deleted the bootcamp drive.

I tried formatting the FAT32 drive as APFS and Disk Utility crashed and I ended up with the small "VM"-named drive (I named it that way, and it was intended to be around 25GB). While I was running with no problems afterwards, after a reboot my main APFS drive (Macintosh HD, 387GB) no longer boots. (and does not show up on the boot menu) and shows up as unformatted on all disk tools I could test. (doesn't show up on DiskUtil at all). I have tried changing the GUID but it still doesn't boot.

I currently don't have a Linux stick, but I'll create one if you need more info. (and if the solution requires one)

overview disk partition

PS: I'm very sorry for the image quality and size, but I don't have my computer at hand to fix them.

You must log in to answer this question.

Browse other questions tagged .