0

my bluetoothd is hitting 100% CPU,on mbp 2013, I have no devices. when I click turn bluetooth off nothing happens, all of the options in option click and shift option click dont change anything, reset smc, pram, tried to turn off sniff mode in bt explorer but clicking link policy does nothing

0

Do you have Android File Transfer installed by any chance? I had a very similar problem about a year ago with my Macbook Pro 2015 after upgrading to High Sierra. Even when it isn't visibly running there is still a background agent running that interferes with bluetooth, try removing it and killing any related processes in activity monitor to see if that solves the issue.

Hopefully removing Android File Transfer will fix the issue for you, but it only worked for me after I reinstalled the version of macOS my mac came with through internet recovery and then upgrading up to High Sierra again. Reinstalling High Sierra alone never fixed the problem. This is only speculation but my best explanation as to why this fixed the issue is that some firmware upgrade that was supposed to happen between OS upgrades failed, and in upgrading from the older macOS to newer macOS provided the option for that upgrade to happen properly.

| improve this answer | |
0

after a couple of days and reboots, trying everything, it stopped

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .