I am the original owner of a mid-2012 MacBook Pro, which is currently running 10.14.6. On it I am running VMware Fusion 11.5.5. I created a VM of OSX 10.11 El Capitan so I could help a relative who uses it.

I do not want to use my personal iCloud account on this VM so I created a new Apple account, validated it, and it now works on a spare iPad. Let's call it my "Test Apple Account".

When the 10.11 installation on the VM reached the point where it asked for Apple Credentials to set up iCloud, et al, I enter the Test Apple Account ID and password, received an approval request on the spare iPad, allowed it, entered the 6-digit code, things were looking good, and then the following dialog box appeared.

enter image description here

I entered the password I always use to sign into this MacBook Pro and after several seconds red text appeared in this dialog box saying it's the wrong password. I tried a couple more times thinking I was misspelling it and now that account is supposedly locked for 24 hours.

I've seen a few forum posts on the Interwebs about this issue but they all veer off on sidetracks, including one on the SuperUser forum. My application is about as clear cut and legal as it gets.


BTW, as a test I used the same Test Apple Account for setting up iCloud in another User account on this MacBook Pro. It worked fine. So what's different about this attempt to sign in to iCloud is that it's on an OSX 10.11 VM in Fusion stead of a 10.14 meatspace MacBook Pro.

Hmm. I wonder if I should be running the VM from that account? I'll check that and report back.

  • Since Apple had locked my Test Apple Account for 24 hours I moved on to other projects, returning today (a couple days later). I opened the 10.11 VM as usual and began the process of logging into iCloud. After providing the Test Apple Account credentials and a period of spinning cursors, a message appeared saying that the account was now unlocked. Instead of then asking me for the password on another device where the Test Apple Account is already active (as per @Old Pro's excellent explanation), it just let me in and all is well. I guess 24 hours of penance is considered sufficient. ;-)
    – user428697
    Commented Jul 28, 2020 at 20:52

2 Answers 2


It does get a bit confusing setting up a new device.

Did you clone a machine to create this VM, or did you create it from scratch? If you cloned it, you could be having some issues about duplicate identifiers.

If you installed this from scratch, it is important to note that the password request is unusual. It is not asking for the iCloud password or the password to the computer (VM) you are using. It is asking for the password to a different computer that is using the same Apple ID. It is doing this to establish trust between this computer and the other one, thereby allowing the other computer to transfer secrets (like your iCloud keychain) to this new computer in a way that Apple never gets to know the secrets.

So pay particular attention to the name of the computer it is asking for the password for. If you have more than one computer with that name, change the name of the other computer(s) using this same Test ID so they are all unique and you know which password to enter.

The password to enter is the password for the user using the Test Apple ID on the named computer.

Also be sure you have iTunes 12.3 or later installed. Somehow iTunes is involved in the multi-factor authentication.

Option 2

The other thing you can do, and in your case you might find it easier and acceptable since this is just a Test Account, is you click on the "Forgot MacBook Pro password" link. It will ask you for the password to a different device, if you have one, until it runs out of devices, at which point it will give you the option to delete all the secrets from your iCloud account. Do that, and now the VM will be the one that needs to authorize the other devices.


This is a new authentication method. It really doesn’t have anything to do with your app or your VM - Apple is using another trusted device to prove you’re in control of the sign in request.

This all started around April 2017:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .