1

I'll start this with saying that the following question is relevant, but the answer didn't solve the problem for me:

I'm running iTunes Version 12.10.7 12.10.8.5, which is the most recent version at the time of writing this on Windows 10. I bought and downloaded the latest season of Doctor Who two days ago.

Initially I had trouble downloading some of the episodes, with error 2072 being thrown in the process. The solution I found online (deleting the Downloads folder in iTunes Media and letting iTunes recreate it) worked to solve this problem and I could download the episodes.

Now they are on my device and I'd like to play them, but the episodes that showed me that error while downloading can't be played now. Starting them opens the player window and displays progress bar and control buttons, but the screen stays black and the progress bar doesn't move.

Other episodes that didn't have this problem downloading are playing fine.

I've tried the following:

  1. Delete and re-download the broken episodes

  2. Delete the broken episodes and re-add them from my device

  3. Check for updates on iTunes and my device (there were none)

  4. Restart iTunes as well as my device.

  5. Check if my device is authorized to play my purchases (it is, otherwise the other episodes of the season wouldn't work either, i guess)

  6. [UPDATE] I also tried downloading the episodes to my iPad (where they do play) and transferring them to my PC from there. However, as soon as they are on my PC, iTunes refuses yet again to play them. This sounds to me like a library corruption. I think I'll try to rebuild it next.

  7. [UPDATE 2] After literally spending hours rebuilding my library (even with exporting and re-importing my old one as xml) it worked for a bit. Right until I closed iTunes and reopened it a while later. Then it got much worse: Now all TV shows that I purchased from the iTunes store either won't play at all or have no sound when they do.

  8. [UPDATE 3] After I did that, I tried completely uninstalling and re-installing iTunes, completely with emptying out my library again. Took me some hours to get everything back up and lo and behold: No changes whatsoever. No TV shows that I bought on the iTunes store can be watched, neither downloaded ones, nor on stream.

  9. [STILL UPDATE 3] I've also unauthorized every device linked to my account and re-authorized my computer. Didn't work either.

0

It could be many things from a missing video codec, to a corrupted iTunes/Quicktime installation, to an old video driver or hardware acceleration on the video driver.

Find a video that doesn't play that you have purchased already. Don't use rentals or streams. This gives you a baseline to test without incurring additional costs.

Make one change at a time then test iTunes with the known troublesome video.

  1. Make sure Windows is up to date run Check for Updates.
  2. Go to your computer manufacturers support web page look up your model and check the video driver version verses the one you see in Device Manager. Upgrade it if it is not the latest version. Some vendors provide tools to make this easier. These tools help you keep your drivers up to date, run such a tool as an alternative option.
  3. Turn off Hardware Acceleration (Display Settings -> Advanced Settings -> Troubleshoot -> Reduce Hardware Acceleration)
  4. Run Disk Cleanup to clear your Temporary folders.
  5. Run virus/malware scans.
  6. Run a Disk Check (Right-click drive -> Properties -> Tools -> Check)
  7. Delete & Re-download the purchased content
  8. Follow this Apple Support guide to completely uninstall, re-install iTunes on Windows. https://support.apple.com/en-us/HT204275 Also uninstall Quicktime if you have that installed.

It's possible that Apple had technical difficulties, some people report a video that had a black screen working properly at a later date with no changes made on their part.

You can actually report the problem and possibly request a refund from Apple for those rentals that didn't work. https://support.apple.com/en-us/HT204084

| improve this answer | |
  • Took me a while to get around to trying all of your suggestions, but unfortunately none of them worked. Thanks for the input, though. – Christian Leimbach Aug 5 at 12:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .