Today I upgraded to Big Sur Beta3 and I cannot install anything with Brew. I get the error:

Error: Your Xcode (11.6) is too outdated.
Please update to Xcode 12.0 (or delete it).
Xcode can be updated from:

Error: Could not find an SDK that supports macOS 11.0.
You may have have an outdated or incompatible Xcode.
Homebrew found the following SDKs in the Xcode install:

I can safely Ignore first error as I have tried everything I state here with XCode 12 Beta2 yielding the same results. The second one which is actually the issue I get seems to come from name changes that makes this Beta to be 11.0 instead of 10.16.

I have read blog post proposing setting special environment variable and I set as below but still does not work.


Any pointer or help is appreciated

  • Xcode 11.6 will definitively not work. Can you switch to Xcode 12, try again and add the error you get (instead of the one you have now)? Otherwise people will just recommend to use Xcode 12.
    – nohillside
    Jul 24, 2020 at 17:11
  • As said in the post, both 11.6 and 12 Beta 2 are not working Jul 24, 2020 at 17:47
  • The problem seems to be numbering as far as I understand the message. So the setting of SYSTEM_VERSION_COMPAT=1 seems to not having the said effect somehow Jul 24, 2020 at 17:49
  • 1
    Sounds like something that should be reported to Apple via the feedback tool. Jul 24, 2020 at 17:50
  • 1
    I'd put this in as an answer but my Mac running Big Sur is currently packed away and I can't get it out just to confirm the exact path of the 10.16 SDK.. The problem you are having is due to Apple confusing the issue by calling Big Sur both macOS 10.16 and macOS 11. Now you have XCode 12 installed you will find the SDK installed as "10.16". Creat a symlink to that SDK called "11.0" and your problem will go away. Jul 25, 2020 at 9:59

3 Answers 3


Same thing happened to me, you need to install the most recent Beta version of command line tools as well as the matching XCode 12 Beta. The same thing also happens with git and other things added by the download https://developer.apple.com/download/more/?=xcode

  • I had to install XCode 12 Beta 3 in addition to Commandline tools Jul 25, 2020 at 11:16
  • WARNING: Only follow instructions in this comment if you are really confident. I simply mode a copy of the MacOS 11 SDK (in the Xcode Beta), and modified some of the variables in the SDKSettings.plist file. This was able to confuse brew into thinking the SDK had the same version as the OS. (I did this with one of the beta SDKs, which brew wasn't detecting properly) Aug 3, 2020 at 1:21

Yep, was broken till I installed Xcode 12.2 Beta 3 / Xcode 12.2 Command line tools Beta 3. Not surprised, this happens every year. I've just received a notification that Xcode Beta 2 Command Line Tools will be automatically installed tonight but I already only have Beta 3 installed. It's a BETA and it's buggy.

Also, Homebrew's response:

$ brew doctor

Warning: You are using macOS 11.0. We do not provide support for this pre-release version. You will encounter build failures with some formulae. Please create pull requests instead of asking for help on Homebrew's Gihub, Discourse, Twitter or IRC. You are responsible for resolving any issues you experience while you are running this pre-release version.


I fixed it by doing: sudo xcode-select --switch /Applications/Xcode-beta.app.

  • 3
    Xcode 12 has been released, and the command line tools can be dowloaded now, but I'm still getting the error. I tried this command to no avail. Sep 18, 2020 at 16:03
  • did you delete old XCode? Sep 18, 2020 at 16:39
  • Also just checked there is macOS Big Sur Beta 7 11.0. Try upgrading to that one and see if it works! I have Beta 6 of Both XCode and MacOS and I have faced no issue! Sep 18, 2020 at 16:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .