0

My daughter's MPB running Catalina displays the following in Storage Management: Screen shot from System Info — Storage — Manage

As you can see, there are two apps shown that come from Steam. But these apps have been deleted in the Finder. The storage is not used anywhere in her Application Support Steam folder (storage used there is 10GB, because of the Subnautica app only). Show in Finder does nothing and Delete... does nothing as well.

We would like to get Storage Management to give the correct info so we actually know if that is still in use storage or that it is just another display bug. We tried several things, including turning off TimeMachine and removing all local snapshots, running Repair from Disk Utility, reindex Spotlight, etc., but nothing so far has helped.

FileVault2 is active on the system.

This question is like this question from Sep 2019 (which did not get an answer so far) but with some more info on what we tried and with a fully up to date Catalina as per today. I can do technical things if people have suggestions, that might answer both questions. In both cases these were Steam apps, so there is a potential Steam on macOS issue here.

3
  • When you say "deleted from Finder" what does that mean exactly? How did you delete or uninstall the Apps?
    – Allan
    Jul 23 '20 at 15:21
  • These are binaries installed by Steam.app (they are games). Such binaries are installed in ~/Library/Application\ Support/Steam/steamapps/common/. She removed them from there (to Trash, empty Trash). It is a basic files system operation. Steam is nothing more than a store frontend, what is downloaded are macOS binaries that can be run.
    – gctwnl
    Jul 24 '20 at 16:39
  • They are not always installed there and additional files can be installed in different locations as well as registered with LaunchServices. Try an App like App Cleaner or see my answer below....
    – Allan
    Jul 24 '20 at 22:21
1

From the Steam Knowledge base on Uninstalling from macOS:

Just dragging the Steam program to the Trash will not fully uninstall Steam. The additional steps below are required.

  1. Open Applications and drag Steam to the Trash.

  2. click Go in the menu bar, hold down the option key until you see the Library folder, and open that folder from the drop-down.

  3. Navigate to Library/Application Support/Steam

  4. Delete Steam data from your computer with one of the following options:

    • If you don't want to lose any game data: delete all files and folders in /Steam EXCEPT FOR the /SteamApps folder (this contains your game downloads and any local save files.)

    • If you're removing all Steam data from your computer: delete the entire Steam folder.

  5. Empty the Trash by selecting Finder -> Empty Trash

Reindex your Hard Drive

If Storage Management (like Steam) is just a front end to all of the system services and it just may not be updated. If it is still showing that the Application is there, it may be required to re-index your drive. In Terminal, issue the following command:

% sudo mdutil -E /
-1

Many apps install files in various locations on your mac. Deleting the app will not delete these other files. I would check if there is an uninstaller for the 2 apps in question. If so run the uninstaller. If not try searching for the app name and see if you can find the other parts of the installed app. If you find these delete them.

1
  • These are games installed by the Steam.app. And the problem is that Storage Management says the apps are there while they are not.
    – gctwnl
    Jul 24 '20 at 16:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .