I'm writing a document about 100 pages with MS Office 2011 for Mac. While I'm editing the content, Word would halt almost every minutes with "Word is finishing analyzing your document" message and a running progress bar.

At first it's only a short pause; however, as the document gets larger, the halt time gets longer too. Now it would take about 10 seconds to finish each "analyzing", and while Word is "analyzing" any operation is not accepted, until the progress bar runs to the end. And that's driving me crazy.

I've done the search and I know that problem existed since 2004. But all this year it seemed not to be fixed with some consistent method.

  • I'm using a Apple Mac OS X version of Office, and I don't have any pieces of software from Adobe installed. No PDFMaker, no PDFWriter, no PDF{anything}, no Acrobat, no Acrobat Reader, no CS, even Flash is manually removed.

  • The "Add-Ins" folder inside Office folder is empty -- I've just ensured that with "sudo rm -Rf *" terminal command under that directory.

  • The "Startup/Word" folder is also empty, too.

  • There is no such template called PDFmaker.dot or PDF{anything} in the template tree: I've check them all.

  • Auto spell check is off. Auto grammar check is off, Auto correction is off. Auto saving is off.

The only thing I've suspected now, is Auto-Text. That document is a technical spec and it's filled with figure captions, table captions, foot-notes, and cross-references. That message would almost surely show up when I'm performing adding something in the middle of document that will push some content to the next page. But I can't find a way to turn-off the auto-update of Auto-Text.

Any idea would be appreciated -- but please focus on MS Office. That's my job and I've to be "compatible" with others.

4 Answers 4


How to stop word 'finishing analysing your document' - Go to: Word/preferences/edit. Then untick 'keep track of formatting'. It'll stop this from happening.

Note however - if you want to 'select all' (from the 'style' box - when selecting a style-type to change), you need to re-tick the above box.

  • Sorry - ignore this comment. This fix used to work - looks like it doesn't anymore.
    – Joss
    Nov 15, 2012 at 4:50
  • If you would like, you can delete your post by clicking the delete link under your post. Nov 15, 2012 at 21:30
  • FWIW: This worked for me under Word for Mac 2016.
    – tcv
    Oct 23, 2015 at 16:18

The problem is inherent to Word, and has nothing to do with any add-ins or any of the settings you mention in your list. The process can be stopped by pressing Command ⌘ + ., but as soon as you take any other action, it will start again. Based on tests I have done, it results from a combination of having tracked changes in the document (even if revision-tracking is turned off) plus automatic page numbering plus a table of contents (or of figures or tables).

If you accept all changes and do no more tracking, Word will stop analyzing the document, regardless of TOCs or automatic page numbering. Or if you leave the tracked changes, Word will stop analyzing the document if you delete both the automatic page numbering (in the footer) from all sections AND the table(s) of contents.

I work on lots of huge Word documents, so I took the trouble to do systematic tests to figure out why Word was constantly stopping to analyze the document. Unfortunately, most of my clients require revision-tracking!

  • Turn-off reversion tracking won't help: I didn't turn it on in the beginning. I've go a huge document from my team member that filled with thousands of reversion tracks, but no auto numbering items. It's really slow when open and edit that document, but no "analyzing document" at all.
    – RichardLiu
    Nov 22, 2012 at 7:52

I had this same problem. I tried all the various suggestions--including those that clearly did not apply to me--and nothing worked. I was literally going to return this MacBook Pro...then I notice a note about copying and pasting the whole document into a new black document and it worked! My starting point was a ~500 page Word 2003 document from a PC. I had already "Converted" it in Mac Word and that hadn't helped. I selected all, copy, and pasted the entire thing in a new blank document and it worked. In fact, I doubled the document size just to be sure and no issues. I've been trying to stress-test it by running various commands and trying various options. So far I've been able to make it go into "finishing analyzing" for only a few seconds at most. I'm so relieved.


I think I found a way to run from it - at least has been working. Open Word and create a blank page; don't write anything; then open the file that you wish to edit and it will open without analysing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .