0

MBA running 10.13.6

I keep a lot of plaintext Notes in a shared DropBox folder, synced between an iMac (also 10.13.6) and my MBA.

The programs I use to access those notes (The Archive and nvALT) suddenly stopped displaying the notes. nvALT gave a Stopped Responding message in Force Quit. The Archive did not.

I tried opening the notes using other tools, including BBEdit and TextEdit. BBEdit showed a row of upside down question marks. TextEdit showed nothing. But I was still able to open and read those notes on the iMac.

On the MBA, I created a new note in BBEdit and saved it to the shared folder.

Now both The Archive and nvALT were able to display the note content.

So, newly created notes display fine, but old ones do not, on the MBA.

I have no idea how to proceed on the MBA, and would be willing to try anything. I am asking here, rather than from the various app developers, because this seems to be a system-wide problem on my MBA.

  • Are the files readable if you log in on dropbox.com and check there? Are newly created notes synced correctly? – nohillside Jul 21 at 8:24
  • Why do you think it’s system wide? You only supplied a single example with a single file type. – Allan Jul 21 at 9:33
  • @nohillside Thank you for the suggestion. I checked DropBox.com and the note content is correctly present in the file. Newly created notes are correctly synced. – jcherfas Jul 21 at 11:29
  • @Allan The files I am interested in are plaintext files, some .txt and some .md. I did test other programs capable of opening those files; BBEdit, TextEdit, Markdown, Word, nvALT, The Archive. Not one of them could show the content of the files. I tried several files too. Perhaps "system-wide" is too strong. What would you suggest instead? – jcherfas Jul 21 at 11:32
  • Looks like your local Dropbox copy got corrupted. Logging out of Dropbox locally, removing the Dropbox folder, and then logging in again might solve this. – nohillside Jul 21 at 11:35
1

If the data is still correct on other computers, your local Dropbox copy might have gotten corrupt for whatever reason.

  • Ensure that all newly created files are synced back (make a local backup if necessary)
  • Log out of Dropbox on the MBA
  • Delete the local Dropbox folder
  • Log into Dropbox again and let it sync the uncorrupted files onto your Mac
| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .