1

Issue summary: Finder window not in focus after switching to it with cmd-tab

Background: I'm using two monitors, A and B. I have 1 Finder window open only on B.

Steps to reproduce:

  1. I start off on monitor A, with focus on say Chrome.
  2. I switch to Finder using CMD-Tab.

Expected Behaviour: Focus in on finder window on monitor B. I can navigate files there by keyboard etc.

Actual behaviour: Finder is shown as in focus (the menu bar shows finde as active application), but focus is on monitor A (where there's no preexisting finder window) rather than on monitor B where there is the only open finder window.

This is clearly not as expected and desired. What's the problem here? How can I solve this?

Version: 10.15.5 (19F101); Other remarks: The menu bar is shown at the top of both monitors A & B.

6
  • Limited workaround: I did two things that together resolved it. I don't know which of the two did the job: a) I unchecked the box next to “Displays have separate Spaces." b) I deleted com.apple.finder.plist in ~/Library/Preferences/, then I logged out and back in. Now I only have one tool bar, and the finder switching works. – Cornelius Roemer Jul 20 '20 at 11:44
  • 1
    This has been an issue since Sierra. Up until High Sierra force-quitting the dock would fix it for a while. Since Mavericks there is no longer any focussed connection between 'desktop' & Finder itself. Someone seems to just have forgotten to properly implement it. – Tetsujin Jul 20 '20 at 11:50
  • Thanks @Tetsujin for the pointer this is a known issue. Is there a central bug filed for this somewhere? The limited workaround is to unchecked the box next to “Displays have separate Spaces" in Settings>Mission Control. Undesired side effect is that the toolbar only shows on main monitor anymore. Deleting com.apple.finder.plist doesn't seem to have done anything (see comment above). For my current workflow relying heavily on finder this is worth activating, but I may deactivate if I need the toolbar a lot. It actually creates extra space for windows, having only one toolbar. May prefer. – Cornelius Roemer Jul 20 '20 at 12:09
  • 1
    I always work with my screens/Spaces in pairs, so always have 'separate spaces' off. It still does it. It also used to be that if you clicked on any visible bit of desktop background anywhere, Finder would come properly to the front. It no longer does. As I have Finder locked to Space 1, this means it no longer even switches to the correct Space, just pretends Finder is front-most in the menu bar. I can't imagine this hasn't been reported, though I didn't. I've been reporting bugs for maybe 5 years or so now… one was fixed, the others are still there. I gave up reporting them. – Tetsujin Jul 20 '20 at 12:15
  • 1
    Thanks, so the best we can do is publish community sourced workarounds. I'm happy with what I found now. Maybe I can help others find a suitable workaround faster. Do you know whether there are other possible workarounds? Using a shortcut like 'undo' 'cmd-z' worked to focus on finder, it's quite annoying but may be better than touching your mouse, combined with cmd-shift-z. – Cornelius Roemer Jul 20 '20 at 12:30

You must log in to answer this question.

Browse other questions tagged .