2

I have connected two external monitors to my MacBook Pro through USB-C to an Anker docking station. The displays appear to be arranged correctly in the settings (screenshot below)

In the image, Monitor 1 is my Macbook Pro. Monitors 2 and 3 are external through the docking station.

The problem is, for some reason monitors 2 and 3 are 'mirrored' in the sense that their displays are identical. However, I can drag my mouse from 2 to 3 as though they were extended. I cannot actually interact with monitor 3 using the mouse however.

Any pointers to fix this bizarre behavior would be appreciated! Thanks for looking

enter image description here

6
  • 1
    A couple of things - could you tell us which you consider to be 1, 2 & 3. Also, test grabbing a Finder window by the title bar & carrying the window with you across each of the 3 screens - what happens?
    – Tetsujin
    Jul 18, 2020 at 17:09
  • Thanks for taking a look @Tetsujin. Monitors 1, 2, and 3 are in order from the left
    – phil
    Jul 18, 2020 at 17:11
  • SO. I am fortunate enough to have another monitor to try which is from a different manufacturer. Replacing #3 with the monitor from the alternate manufacturer solves the problem.
    – phil
    Jul 18, 2020 at 17:13
  • It seems like OSX is getting confused having 2 displays with the same name or manufacturer model number?
    – phil
    Jul 18, 2020 at 17:14
  • 1
    @Tetsujin I can drag a window from 1 to 2, and 2 back to 1. If i drag from 2 to 3, the window appears to go to drag somewhere, but does not display on 3. It is all very bizarre. I will post the "fix" of using a display from an alternate manufacturer/model as an answer when I get everything set up and it seems stable
    – phil
    Jul 18, 2020 at 17:20

2 Answers 2

2

You could try using the program I wrote, displayplacer, which was developed to deal with the wonkiness of macOS screen layouts. For your particular situation, you'll want to run displayplcer list to output your current monitor setup. Then, edit that profile so that it isn't mirroring. Mirrored monitors are after the + sign in the id section. It'll take a bit of fiddling. Once you get it working though, you can assign that displayplacer command to a hotkey. Then, whenever this happens again (usually every time you plug in), type the hotkey to set your monitors to the correct layout.

0

The solution in my case was to use a monitor from a different model/manufacturer for display #3. When monitors 2 and 3 were identical in make and model, the bizarre pseudo mirroring would happen. When I changed out #3 to a different make/model everything worked normally.

Also check out Jake Hilborn's answer for displayplacer on github if using a different monitor is not an option

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .