1

I'm on OSX 10.15.5 and running Apache with virtual hosts, and SSL is enabled. certbot renew works fine, but in the log I'm seeing this message. (Certbot 1.5, and Openssl 1.1

The "Unable to load ssl_module" bit. However - it still works. Just giving that message.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Processing /etc/letsencrypt/renewal/robert-chalmers.uk.conf
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Cert is due for renewal, auto-renewing...
Unable to read ssl_module file; not disabling session tickets.
Plugins selected: Authenticator apache, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for robert-chalmers.uk
http-01 challenge for www.robert-chalmers.uk
http-01 challenge for quantum-radio.net
http-01 challenge for www.quantum-radio.net
http-01 challenge for www6.robert-chalmers.uk
Waiting for verification...
Cleaning up challenges

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
new certificate deployed without reload, fullchain is
/etc/letsencrypt/live/robert-chalmers.uk/fullchain.pem
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
2

2 Answers 2

1

The problem was Port 80 had become blocked. Once opened again. Everything works as normal.

1
  • 1
    Blocked in what way? Can you elaborate?
    – cetcet
    Commented Aug 26, 2020 at 19:15
1

I had a Ruby server that had opened the port and it had not closed. Found that and stopped it. All good now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .