0

My wife and I purchased an desktop iMac A1311 from Facebook market place. It was perfectly functional but the seller hadn’t removed any of their personal info before selling it so my wife erased it (I believe it was a factory reset that she did). The computer now only boots in recovery mode, and we are unable to reinstall the operating system because it’s requiring the password of the person that sold it to us. We’ve tried contacting them for either a password or even proof of purchase to bring it to Apple, but they will not reply.

So currently we are trying to reinstall the macOS from a bootable thumb drive. I succeeded in making the drive from another computer, but that’s only lead me to more hiccups. For one, I can’t get the computer to start up in the boot menu. No matter what keys I hold down at it opens in recovery mode.

I thought I figured out how to work with this when I went into the operating system installer and saw my thumb drive as an option, but when I click on it, it says the disk is locked. So I’ve been trying to figure out how to unlock it, including the verify and repair, but when I clock repair it says it cannot be done.

So help with any of this would be greatly appreciated. Either getting to the boot menu, unlocking the disk, or even better if there is some other easy solution to getting around the issue with the password to get macOS up and running!

  • "I succeeded in making the drive from another computer,..." Another Mac, or did you use a Windows or Linux PC? I use DiskMakerX (free!) to build bootable installers. Never lets me down and easy to use. But you gotta have another Mac and the full installer from Apple on that Mac. – Steve Chambers Jul 18 at 0:39
  • Yes on another mac. I didn’t have any problem making the bootable thumb drive, the only problem is that when I click it on the computer I’m trying to install on it says “The drive is locked.” – Amanda Jul 18 at 0:49
  • It may be locked via firmware password. You will need that password from the previous owner. Replacing the drive might fix the issue but we don't know where the password was set. A pic of the screen asking for the password might help... – Steve Chambers Jul 18 at 13:22
1

I solved the problem! I looked up how to erase a computer when you plan to sell it, was able to do so in recovery mode by opening up the disk utility and selecting erase on the hard drive and setting it to the maximum security. This successfully removed the need for the previous owners password and was able to reinstall macOS as per normal from there!

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .