1

I use iCloud photos, on a new Catalina MBP and on iOS 13.6.

on both of those devices I see 7201 photos.

yet, on iCloud.com I see 7200.

there is always a one photo difference.

Adding and removing photos made no difference, iCloud and the Apple devices just gain and lose photos normally. Yet the difference is always there.

Any ideas how to debug?

2

On your Mac, create a Smart Group with the filter:

Photo | is | unable to upload to iCloud Photo Library

This should hopefully display the problematic photo, which you can try to delete and re-add.

https://daringfireball.net/linked/2018/01/26/apple-photos-unable-to-upload

  • 1
    I was super excited about this, but it showed no photos that are "unable" to upload. I'm at a loss... – Woodstock Jul 17 '20 at 21:37
  • I've now even reset my MacBook and iPhone and resynced, still the same. After deleting EVERY photo and resyncing! – Woodstock Jul 18 '20 at 12:04
  • 1
    Solved it :) thanks @pkamb, check out my answer below – Woodstock Jul 19 '20 at 8:28
2

Whilst a great answer from @pkamb. In the end my wife thought of a way to resolve this.

  1. On the Mac (which has 7201 photos), divide this into two albums, one with 3600, and the other with 3601 Album-A and Album-B.

  2. On iCloud check which album isn't matching, i.e. Album-A had 3601 on my Mac, but in iCloud it showed only 3600.

Repeat this process dividing the photo set in two continuously.

It took about 30 mins, but eventually I had narrowed it down to a set of photos with say 36 images. I then manually found the offending photo.

So, weirdly, it was a photo that literally didn't appear in iCloud photos. Yet when re-syncing from iCloud it would come down to a blank device. Weird.

Anyway, on my devices this innocuous photo, had a little cloud icon in the corner. again weird, not other photos had this.

I deleted it manually from both devices.

Since then all devices are in sync with the cloud, and re-syncs are working.

So there you go, strange.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .