0

I have a Macbook Pro mid-2012 15-inch with Catalina 10.15.5. I was continually getting messages that my system hard drive was full. I went to the Manage space, and started deleting large files from downloads, etc. I realized that as they were deleting, the space in other was getting larger with every additional thing I deleted. The trash is empty, but there is still no space on my computer (like 8mb). Not sure what is going on.

Thanks!

-1

This could be due to the files still being kept in APFS snapshots created by Time Machine, so you could try running the following in Terminal to clear some of them:

tmutil thinlocalsnapshots / 1000000000 1

The documentation for “tmutil” can be read using the command “man tmutil”, it says:

     thinlocalsnapshots mount_point [purge_amount] [urgency]
             Thin local Time Machine snapshots for the specified volume.

             When purge_amount and urgency are specified, tmutil will attempt
             (with urgency level 1-4) to reclaim purge_amount in bytes by
             thinning snapshots.

So the above command thins the snapshots on the Mac’s internal drive (which is normally mounted at the path “/”), to reclaim 1GB (1,000,000,000 bytes) with urgency level 1.

The output of the command will list the snapshots it removed. In this example output, 1 snapshot was removed:

Thinned local snapshots:
com.apple.TimeMachine.2020-07-17-200440
5
  • 1
    in the spirit of teaching it would be good if you added exactly what you are proposing, and what the options you are you specify so that the OP will not just be entering commands blindly, "run the time machine utility in a terminal with the thinlocalsnapshots command which does ____" and so on. Jul 17 '20 at 13:52
  • Unfortunately, it's not. I ran that in terminal and it returned that it had thinned localsnapshots; however, I still only have 24mb and the "other" is still ~152GB. Any other ideas?
    – James
    Jul 18 '20 at 2:55
  • @James: try running “thinlocalsnapshots” again with a higher “purge_amount”, but if that doesn't help I’m afraid I'm not sure what else could be causing your problem.
    – Rinzwind
    Jul 18 '20 at 7:50
  • APFS snapshots often get the blame, but I think they're actually not the problem most of the time.
    – benwiggy
    Jul 18 '20 at 10:00
  • Yeah, there's no output, so I guess there aren't any snapshots to remove?
    – James
    Jul 18 '20 at 18:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .