8

Lion doesn't seem to be giving out DHCP addresses when I turn on Internet Sharing. My firewall is off, I create a shared network with no security sharing ethernet->wifi. In Network Preferences the Wifi connection shows as yellow, with a self-assigned IP, and any device I try to connect (e.g., iPad) doesn't get an address. Help!

3
  • I have the same problem :(
    – Elliot
    Feb 13, 2012 at 4:58
  • What does contain the field System Preferences > Network > Wi-Fi > Advanced... > TCP/IP on your DHCP server? What is the output of ps ax | egrep '[ /](PID|boo|nat)'?
    – dan
    May 12, 2012 at 22:28
  • I am seeing a similar issue on macos ventura, I do not see bootp process when I enabled the internet sharing in the settings menu after a reboot, none of the above steps worked for ventura, I am happy to provide any logs if needed. Tried lot of things not sure if this is a bootp or launchd issue.
    – Aravind
    May 30, 2023 at 1:29

7 Answers 7

7

I finally figured it out.

  • You said your Firewall is off. You should double-check. This will definitely cause Internet Sharing to not work. System Preferences -> Security & Privacy -> Firewall.
  • In the "Sharing" panel, change your Computer Name to something simple. Instead of "Elliot's MacBook Pro", use "MBP".
    • Turn off Internet Sharing (if it's on). Make sure you have set "Share your connection from:" to "Ethernet", and "To computers using:" to "Wi-Fi". Change the "Wi-Fi Options..." and save.
  • If that didn't work: Turn off Wi-Fi on your Lion Mac. Make sure you have internet access from Ethernet, and that it works (test a site in a browser).
  • For your Wi-Fi connection, set "Configure IPv4" to "Using DHCP". In the "DNS" tab, delete any existing entries.

Hope this helps!

4
  • 1
    No evidence of the firewall breaking InternetSharing in any way. Moreover this would be a fatal security bug :<.
    – dan
    May 12, 2012 at 22:32
  • Turning off firewall solved the issue for me as well, and found others using Google. Thanks for the tip. Dec 19, 2013 at 21:19
  • 2
    A more specific answer: the "Block all incoming connections" advanced firewall option made Wi-Fi sharing not working. Dec 27, 2013 at 10:44
  • I think removing a space from my computer name fixed the issue for me on High Sierra...
    – heyfrank
    Aug 10, 2018 at 18:05
5

This thread along with https://discussions.apple.com/thread/2108373 helped me.

  1. I turned off all internet connection sharing.

  2. I deleted the following files:

    /Library/Preferences/SystemConfiguration/com.apple.nat.plist
    /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist
    /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist
    
  3. Restarted

  4. Turned on Internet Sharing

This resulted in Internet Sharing sharing giving the client the correct DHCP lease details.

5
  • This is the only fix that worked for me form the answers here. It might be worth mentioning that you can back up those files before deleting them. :) Jan 23, 2014 at 16:18
  • If you drag the files to the Trash then there is no real need to back them up... However, this method, unfortunately, didn't seem to work for me on Mountain Lion - DHCP still doesn't work... Jan 21, 2017 at 2:55
  • This just solved the problem for me in Mojave, so this solution is not outdated as far as I know. Jan 14, 2019 at 4:00
  • Tried other ideas from other pages but this answer did the trick on Ventura 13.5... I had internet sharing on (and working) when I started the upgrade from 13.4.1 but after the upgrade laptop stopped handing new DHCP releases for new connections and the old connections would work if I manually set the IP on the client side. Needless to say, this was not sustainable and it looks like, upgrading while sharing internet did something to one of the above plists and deleting and restarting reseted them. Thanks for sharing this solution!
    – Halil Sen
    Aug 15, 2023 at 11:29
  • I have no idea why this worked, but it worked for Ventura 14.0 when I was running into an issue with multipass not provisioning IPs: github.com/canonical/multipass/issues/3209
    – Sienna
    Sep 7, 2023 at 18:10
1

This worked for me on 10.9 Mavericks (build 13A598)

  1. Open Terminal and run

    sudo launchctl remove com.apple.bootpd
    
  2. Re-enable Internet Sharing

This guy below has a basic explanation of what he's doing if you want more of an explanation and debugging process.

http://ben-collins.blogspot.com/2010/08/mac-os-x-internet-sharing-problems.html

2
  • 1
    Doesn't work on Mountain Lion: launchctl remove error: No such process Jan 20, 2017 at 22:40
  • Works for me on 10.12.x
    – Rdpi
    Aug 20, 2017 at 6:03
1

I have OS X El Capitain and the following works for enabling the sharing of internet connection by devices connected to the ethernet connection (the local network) via the wi-fi network (the internet connected network).

1) Network Connection --> the local connection in automatic 2) Sharing --> Internet Sharing (set Share your connection to the Wi-Fi in the drop-down menu and tick the ethernet connection)

At this point if you go back to network connection you will see the wifi with a green dot and the ethernet with a yellow dot. Keep going, as (1,2) may not be enough, yet.

3) Security --> Firewall Options --> remove the tick to "Block all incoming connection". (NB this is different than disabling your firewall!).

Then you will start getting queries like "do you want service XYZ to accept incoming connection?". The answer to most of those questions depends on your security paranoia (mine is high) except for one!

4) Accept bootpd (which is the daemon for DHCP).

In retrospect the last step is sort of obvious: when the poor device on the (local) ethernet network send a DHCP request to your Mac to get an IP address from the perspective of your Mac this is an unsolicited incoming request and therefore the Firwall will quietly drop it.

If you don't want (3,4) then you may set up manually the IP of the local device and your Mac to a pair of addresses on the same subent. So somenting like n0.n1.n2.nDevice and n0.n1.n2.nMac where the Ns are any number in 1-254.

0

I'm using it. InternetSharing and Firewall: on do work together. (It's already huge enough a security shame to have to start a wireless network with WEP). Beware: you should not ride the raw Internet with your Firewall: off.

On the other hand I'm also sure of another behaviour. InternetSharing doesn't start bootpd if the network connexion to Ethernet isn't up, i.e. doesn't have an IP valid address. (And bootpd is the daemon which distribute IP addresses on the Wi-fi side).

Within the valid network configuration on top of which you want to build a sharing of your Ethernet connexion,

  • the Ethernet connexion should be marked as green, with a valid IP Address,
  • the Wi-Fi connexion should be marked as yellow, with Network Name: No network selected.

When you start Internet Sharing 2 details will change:

  • the Wi-Fi icon in the menu bar should switch to grey with a white arrow,
  • the Wi-Fi connexion should be marked as green, with Network Name: Internet Sharing: on.
0

This issue can also manifest itself when you go to the Firewall Options and Block all incoming connections is enabled.

1
  • However, if does say (in Mountain Lion) beneath the checkbox that DHCP will not be blocked. Jan 21, 2017 at 3:01
0

On El Capitan, the following steps worked for me:
1. Open security and privacy under system preferences
2. Click on FireWall
3. Click FireWall Options...
4. Uncheck "Block All Incoming Connections"
5. If it was unchecked, look for "bootpd" in the box below it
6. Click where it says "Block Incoming Connections" next to bootpd
7. Select "Allow Incoming Connections"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .