I'm running Lion (10.7.3). In any application, when I bring up the "Open File" dialog, it shows an outdated list of files — files I deleted hours ago still show up; files I recently created don't show up.

If I leave the dialog open for 30 to 60 seconds, it will eventually refresh and the current folder contents will be shown. But this really slows me down.

Any ideas about how I can speed up the refresh time so I can get back to work?

Going to a different folder and then back to the first folder doesn't help — the list of files is still outdated.

Closing the dialog and then reopening it doesn't help — the list of files is still outdated.

  • How's your hard drive's health? Feb 7, 2012 at 16:10
  • @StevenFisher: Doing fine, I think. I haven't noticed any other harddrive-related issues. SMART status: Verified.
    – smokris
    Feb 7, 2012 at 17:03
  • That's not conclusive, but it's a good indicator that things are fine. :) Feb 7, 2012 at 17:48
  • Get Info on a folder displays WRONG number of items: forums.macrumors.com/showthread.php?t=1318795 Finder not showing files discussions.apple.com/thread/3649473?start=0&tstart=0 It seems Apple has dialed down the priority of asynch Finder operations too far. Sometimes Finder handles like something from a Mac+ Feb 7, 2012 at 19:53
  • @WayfaringStranger: Oddly I never seem to have this problem with Finder, just in other applications' Open File dialogs.
    – smokris
    Feb 7, 2012 at 22:04

1 Answer 1


I don't know if this is relevant, but many times when I go to any kind of file dialogue or even just click on some tool or something, I get a few seconds (or more) of beach ball while my second HD (non-boot drive with most of my documents/non-OS files) wakes up and gets up to speed. I can hear it revving up and when it gets to speed the OS unfreezes… so maybe if your file directories are being cached in memory or the drive cache, when the HD wakes after 30 secs for whatever reason, it updates the directory lists in memory?

I'm thinking this isn't super common complaint so maybe it's HD settings specific like my problem (I think I set my 2nd HD to have energy saving options somewhere when I installed it and haven't found a way to have it spinning 24x7.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .